0

i have rpm package(ex: sqldeveloper-4.0.3.16.84-1.noarch.rpm), but i cannot use 'alien' from software center ubuntu when is i try install 'alien', i have a bug:

root@temo:~# sudo apt-get -f install alien

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
alien : Depends: debhelper (>= 7) but it is not going to be installed
     Depends: rpm (>= 2.4.4-2) but it is not going to be installed
     Depends: rpm2cpio
 skype:i386 : Depends: libc6:i386 (>= 2.3.6-6~) but it is not going to be installed
          Depends: libc6:i386 (>= 2.7) but it is not going to be installed
          Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
          Depends: libqt4-dbus:i386 (>= 4:4.5.3) but it is not going to be installed
          Depends: libqt4-network:i386 (>= 4:4.8.0) but it is not going to be installed
          Depends: libqt4-xml:i386 (>= 4:4.5.3) but it is not going to be installed
          Depends: libqtcore4:i386 (>= 4:4.7.0~beta1) but it is not going to be installed
          Depends: libqtgui4:i386 (>= 4:4.8.0) but it is not going to be installed
          Depends: libqtwebkit4:i386 (>= 2.2~2011week36) but it is not going to be installed
          Depends: libstdc++6:i386 (>= 4.2.1) but it is not going to be installed
          Depends: libx11-6:i386 but it is not going to be installed
          Depends: libxext6:i386 but it is not going to be installed
          Depends: libxss1:i386 but it is not going to be installed
          Depends: libxv1:i386 but it is not going to be installed
          Depends: libssl1.0.0:i386 but it is not going to be installed
          Depends: libpulse0:i386 but it is not going to be installed
          Depends: libasound2-plugins:i386 but it is not going to be installed
          Recommends: sni-qt:i386 but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Plz help in installing alien.

  • First Ubuntu doesn't use rpm packages, and did you run sudo apt-get -f install as suggested by apt? – George Udosen Mar 12 '17 at 5:59
2

alien often produces unsolvable dependencies in the package being installed due to differences in the naming of libraries in the Debian and Red Hat operating systems, however in Ubuntu 16.04 and all supported versions of Ubuntu it is possible to build a Debian package of Oracle SQL Developer using sqldeveloper-package from the default Ubuntu repositories. Open the terminal and type:

sudo apt install sqldeveloper-package

This utility will require you to download the architecture independent archive from http://www.oracle.com/technetwork/developer-tools/sql-developer, identified as "Oracle SQL Developer for other platforms", "Oracle SQL Developer for Multiple Platforms" or "Oracle SQL Developer for Linux and Unix" (depending on which version you are building), to create the Debian package from.

0

It's complaining that the alien package needs (depends on):

debhelper version 7 or later (version 9.20160115ubuntu3 is in the repositoires)
rpm version 2.4.4-2 or later (version 4.12.0.1+dfsg1-3build3 is in tyhe repositories)  
rpm2cpio no version specified (version 4.12.0.1+dfsg1-3build3 ...)  

Read man apt-get, you may be able to use --install-suggests or -o APT::Install-Recommends=1 to apt-get.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.