1

I have an ASUS laptop with ubuntu dual booted with windows 10 on separate partitions. The other day after booting into the windows partition, I found that when I try to boot back to the ubuntu partition I only get a black screen and can not boot into ubuntu.

I posted the initial problem here: trouble booting into dual booted ubunutu after running windows and found a possible solution to try using boot-repair.

Using boot repair, I get the message that the boot-repair was successful, however the black screen problem still persists when trying to boot into ubuntu from GRUB.

Boot repair gives me the following URL for troubleshooting in case the problem persists (which it does): http://paste.ubuntu.com/24154080/

I would like some help going through the above URL and troubleshooting to solve the problem of not being able to boot into ubuntu.

  • Comments are not for extended discussion; this conversation has been moved to chat. – Mitch Mar 11 '17 at 12:13
0

This is not the answer, but it lets me show you a picture of what should work when booting from a Live USB and reinstalling Grub.

The nicely laid out instructions from 'How to Ubuntu' on how to repair Grub with a live USB (http://howtoubuntu.org/how-to-repair-restore-reinstall-grub-2-with-a-ubuntu-live-cd) are unfortunately incorrect if using an EFI system. Adding one extra line lets it work, but it took a lot of chasing down other possibilities before realising this.

As an extra bonus, it also didn't actually work for you even with the line added :(

Here's my Live USB grub fixing that did work:

How To Ubuntu Grub Fix with /mnt/boot/efi line added

In this case, the Ubuntu installation was on sda7 (for you it was sda5) and the EFI partition was on sda2 (for you it was sda1). Everything else would be the same.

(incidentally, the 'grub-probe: error ' is for sdb1 which is the Live USB so can be ignored)

Why it's throwing up errors for you, I unfortunately don't know. The main reason for suggesting this was just a quick check to make sure that boot-repair had done it's job correctly and then we could look at other reasons for why you were getting the black screen.

I've used the same instructions before and they worked fine, but it must have been for a machine without UEFI.

I assumed it wasn't working firstly because the Live USB wasn't in UEFI mode, so might not have permission to write to the EFI partition, which in turn meant finding out that the Asus 'One Time Boot Menu' was accessed by pressing ESC on bootup and that they don't have Legacy Boot Options and UEFI Boot Options listed separately (which is what I've seen on a Dell laptop & an HP laptop) and it seems you need to choose 'Legacy USB support' to be disabled to ensure that it's booting in UEFI mode for your laptop (and I assume for other Asus machines as well).

Unfortunately we ended up down a rabbit hole of other possibilities before I realised the How To Ubuntu instructions are not taking an EFI boot partition into account.

If the now adjusted instructions do work, the main thing it helps with is to confirm that Grub is installed correctly on your machine.

It's a bit disconcerting that it's throwing up errors when trying to install Grub, but it might be best to just trust that boot-repair would give you errors if it hadn't been able to do it's job.

So use boot-repair as you did before, assume that Grub is fine and either troubleshoot along the lines of brndn2k's suggestion of looking here: My computer boots to a black screen, what options do I have to fix it? or try reinstalling Ubuntu again.

I've distracted you enough with this line of enquiry :)

Bon chance!

  • Awesome. I managed to get the ubuntu option back to GRUB (mentioned that i lost it earlier) by using boot-repair again. Following these directions I actually able to run "grub-install /dev/sda" and "update-grub" without any errors!! So we seem to be on the right track now. Only one problem is at the end when un-mounting everything (according to the help ubuntu page) on the very last command "sudo umount /mnt", i get the error: "umount: /mnt: target is busy". I think if we can fix this i should be all set. I don't want to just exit and reboot anyway becasue if i remember correctly [CONTINUE ->] – derek Mar 11 '17 at 13:29
  • [CONTINUED] thats how i lost the ubuntu boot option at GRUB before – derek Mar 11 '17 at 13:30
  • Ok. I just read online that running "sudo fuser -vm /mnt" will give a list of which processes are running on /mnt so that i can kill them and run that final "sudo umount /mnt" command. There is only one, for /mnt i have "USER: root" "PID: kernel" "ACCESS: mount" "COMMAND: /mnt". It doesn't seem correct that i should have to kill the kernel to umnount /mnt. – derek Mar 11 '17 at 15:25
  • I am able to consistently run "grub-install" and "update-grub" successfully and without any errors using the method pictured above. After this, when unmounting everything using the directions in this link: howtoubuntu.org/… when i get to the last command "sudo umount /mnt" the computer is unable to and says "target is busy". If i reboot without this command then i still get the black screen problem. I have also tried rebooting without using any of the umount commands (after update-grub successfully completes) [CONTINUE -->] – derek Mar 11 '17 at 16:29
  • [CONTINUED -->] and this also leaves me with the black screen problem when booting ubuntu. Since grub-install and update-grub now succesfully work, I assume that if i can get this last "sudo umount /mnt" command to work then boot problem would be fixed – derek Mar 11 '17 at 16:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.