When I try to start XAMPP with sudo /opt/lampp/lampp start command it gives me a message like this.

Starting XAMPP for Linux 1.7.7...
XAMPP: Another web server daemon with SSL is already running.
XAMPP: Starting MySQL...
XAMPP: Couldn't start MySQL!
XAMPP: XAMPP-ProFTPD is already running.
XAMPP for Linux started.

What is this and how can I find what was this another web server daemon with SSL. How to stop this server ?

up vote 9 down vote accepted

This is a peculiar error you will get if you run XAMPP in LINUX.

Assumption: XAMPP is unzipped @ /opt/ folder.

If you get the error "XAMPP: Another web server daemon with SSL is already running" when you run ./lampp start. Simply follow the steps below to get rid of this error:

  1. Open the file /opt/lampp/etc/httpd.conf.

  2. Search the Listen 80 and change it to some other port (e.g. Listen 2145) (Line No. 40).

  3. Open the file /opt/lampp/etc/extra/httpd-ssl.conf.

  4. Search the Listen 443 and change it to some other port (e.g. Listen 16443) (Line No. 39).

  5. Open the file /opt/lampp/lampp

  6. Search for the port testport 80 and replace it to testport 2145. Also change the testport 443 to testport 16443. (Happens to be the Line No. 197, 214)

  7. Now go and run /opt/lampp/lampp start. It should work now.

Note: Line numbers may be different.

  • Tnx bro.. :) Is there any way to stop that previously ruining server ? – Asanka400 Dec 20 '11 at 9:26
  • That depends on which server it is, if any daemon process is using it,chances are less,first you need to know that which process is using the port by default. – sum2000 Dec 20 '11 at 9:34
  • This is the error i am getting if i click on phpmyadmin page in xampp. Error MySQL said: Documentation #2002 - No such file or directory The server is not responding (or the local server's socket is not correctly configured). – Ram Nov 20 '13 at 8:25

I have similar problem and found the issue caused another service already running on port 443 (SSL).

Check running listener: sudo netstat -tunap | grep LISTEN. Mine had vmware-hostd and cupsd listed.

Refer to http://www.apachefriends.org/en/xampp-linux.html, we need turn off lamp's SSL service using the command sudo /opt/lampp/lampp stopssl, which deactivates the SSL support permanently.

Now you can start xampp: sudo /opt/lampp/lampp start

  • Changing ports to 2145 and 16443 didn't work for me. This did, and I need no ssl.. thanks – user568021 Apr 6 '14 at 13:29

In the terminal, execute sudo /opt/lampp/lampp disablessl. This should disable ssl, after which xampp will start successfully again.

For Ubuntu 16.04

  1. First use the command nmap localhost and check whether port no.443 is running.
  2. If it's running then use command sudo kill $(sudo lsof -t -i:443)
  3. Then open xampp control panel and start the apache server from there also.
  4. It will start running.
  5. Or you can also navigate to the /opt/lampp
  6. Then start it by giving command ./sudo xampp start

It finally works

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.