2

Whenever I click on software updater it says Failed to download repository information.

It's been saying this for the past few days now and I don't know why, my Internet connection is fine, I am able to manually download software.

Sometimes it crashes when I click okay, then attempts to look for updates again and gives me the same message.

Any ideas?

[EDIT] I just tried an answer posted where I reset where the downloads come from, but I was left with this message:

W:The repository 'http://ppa.launchpad.net/noobslab/noobslab-conky/ubuntu xenial Release' does not have a Release file., 
W:Data from such a repository can't be authenticated and is therefore potentially dangerous to use., 
W:See apt-secure(8) manpage for repository creation and user configuration details., 
W:https://content.runescape.com/downloads/ubuntu/dists/trusty/InRelease: Signature by key AAC9264309E4D717441DB9527373B12CE03BEB4B uses weak digest algorithm (SHA1), 
E:Failed to fetch http://ppa.launchpad.net/noobslab/noobslab-conky/ubuntu/dists/xenial/main/binary-amd64/Packages  404  Not Found, 
E:Some index files failed to download. They have been ignored, or old ones used instead.
10

Open Software & updates

Change the server from Download from:

enter image description here

For best download speed choose your country or a country next to you. Alternatively, let ubuntu test and decide the fastest server by clicking the Select best server button.

enter image description here

| improve this answer | |
  • thanks I just tried this but I got another error, it was too big to fit in a comment so I've added it to the original question. Does it make any sense to you? – AdLinux Mar 10 '17 at 8:26
  • @Ajt8000 on the Other Software tab, see if you have this ticked http://ppa.launchpad.net/noobslab/noobslab-conky/ubuntu, if so, un-tick it and try. – Sirajus Salekin Mar 10 '17 at 10:14
  • 1
    I am living in India, and changing my server to India didn't help. But changing my server to United States help. In short simply changing the server to your country may not work. You have to do a few trial and error tests to find the right server for you. – Sonevol Nov 18 '17 at 22:18
1

Your basic problems are with two PPAs that you're using, the Noobslab and Netscape repos. The error that you get with netscape is just a warning; it won't break your update process. However the Noobslab repo is not compatible with your Ubuntu version (16.04) so you need to delete this source from Software & Sources > Other Software

After doing this step you should be able to update everything.

See error details from these posts:

How to fix apt: Signature by key uses weak digest algorithm (SHA1)?

How can I fix a 404 Error when using a PPA or updating my package lists?

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.