0

So I just dual booted my Windows 10 with ubuntu via usb (which was a bit of a struggle in of itself) and I realized my usb wifi adapter wasn't connected. So I did some digging and people said get ndiswrapper so I can get the proper driver to get the wifi working. So I installed ndiswrapper.common and ndiswrapper.utils as .deb files onto a usb and opened them in ubuntu. I got temporary Internet via usb tethering to my phone. I read somewhere to install common first so I tried that and it appeared to have installed through Ubuntu software.
Then I tried to install the utils and then everything just stopped working.

After that nothing would download/update.

Many people gave different suggestions,

-sudo apt-get update

-sudo apt-get upgrade (this one comes back with unmet dependencies: ndiswrapper-utils-1.9:i386 : depends: ndiswrapper-common:i386 E: Unmet dependencies)

-sudo apt-get install aptitude (same error as above)

-sudo apt-get -f install (same as above but with resolve generated breaks, this may be cause by held packages E:unable to correct dependencies)

-sudo dpkg --configure -a --force-all (this one seemed to have done something...)

None of these work. It's been more than a few hours and I'm running out of options with my extremely limited Linux knowledge. Can someone help point me in the right direction?

Thank you!

P.S. Also maybe worth noting up on the top right there is a red circle with a white line going across the middle like a do not enter sign. It says: "...error:Brokencount>0..."

EDIT: when I try gksu software-properties-gtk it tells me gksu is not currently installed. So I try to install it through the terminal but it wont install because of the same unmet dependencies error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.