2

I have Ubuntu 16.04 LTS on a brand new Dell XPS 13. I bought a Microsoft Arc Touch Bluetooth Mouse (the one without the dongle). My current problem is that my Bluetooth manager is not able to discover my mouse. All the other problems related to this question are dealing with a bug that, once paired, causes the mouse to not work properly. My problem is that I can't even pair it, because I can't see it. Here is a comprehensive list of what I have done and tried:


I have the latest versions of bluez and blueman

bluez: 5.37-0ubuntu5  
blueman: 2.0.4-1ubuntu2  

So, that rules out this solution: Microsoft Arc Touch Mouse doesn't working on Ubuntu 14.04


I have tried the solution here How do I use a Microsoft Designer Mouse with Ubuntu 15.10 to no avail.


When I run hciconfig -a | grep "HCI", I see that my bluetooth version is 4.1 (0x7).

This rules out SOLVED - Microsoft Designer Mouse not connecting to Ubuntu 15.10.


I suppose the only thing I wasn't able to fully try was the solution to Surface Arc Touch Mouse not working with Ubuntu 15.04. This is because the solution itself is kind of vague and gives no clear instruction on how to do the steps that are listed. But again, this is for somebody who could see the mouse, but could not connect.


I don't know what else to try. I have tried discovering the device through Ubuntu's built-in Bluetooth manager as well as the bluetoothctl command with scan on.

1
  • 1
    This issue has been solved. For some unknown reason, pairing the device with a Windows 10 operating system, then removing that device on said Windows device, allowed the mouse to be discovered and paired on my Ubuntu system with no problem whatsoever. If anyone has extensive knowledge on bluetooth and can provide a possible explanation, it would be appreciated because I'm quite the curious creature. If not, though, that's fine. I'll leave the question up for a couple days and then close as solved. Mar 10 '17 at 17:38
3

I had the exact same problem. I tried multiple methods including the one described here. Nothing worked.

However I found a way to fix it.

I used this tutorial to get me there.

I think the problem was that I didn't have my bluetooth le set to on. Which is how the arc is discovered/connects

sudo btmgmt le on

This seemed to fix everything.

Not sure why it was off. Headphones work now also.

1
  • how to set this definetively?
    – lf_araujo
    Jul 20 '20 at 10:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.