0

I tried following the steps on the answers to this question: Make gedit embedded terminal colours the same as the default terminal

However, none of them work. I'm using Ubuntu 16.04 LTS

I tried changing the settings using dconf-editor but the changes are not reflected in gedit

1 Answer 1

2

I ran into the same problem today and stumbled on this question. Sadly it had no answer. Happily, I manged to figure it out. HTH someone else.

I'm using an Ubuntu 16.04 VM, and followed the same tutorial, and had the same results.

The issue lies here, in /usr/lib/x86_64-linux-gnu/gedit/plugins/terminal.py lines 88-98:

def get_profile_settings(self):
profiles = self.settings_try_new("org.gnome.Terminal.ProfilesList")

if profiles:
    default_path = "/org/gnome/terminal/legacy/profiles:/:" + profiles.get_string("default") + "/"
    settings = Gio.Settings.new_with_path("org.gnome.Terminal.Legacy.Profile",
                                          default_path)
else:
    settings = Gio.Settings.new("org.gnome.gedit.plugins.terminal")

return settings

When the plugin gets the terminal settings, it first checks the dconf-editor path for the default terminal settings, which, if yours is like mine, only has the use-theme-transparency setting. As a result, the embedded terminal has no settings to actually use. I figure the hard way to fix this would be to replicate the keys in org.gnome.gedit.plugins.terminal into the org.gnome.Terminal.ProfileList. Instead, open terminal.py, comment out the if statement, and force the settings to use the org.gnome.gedit.plugins.terminal settings.

    def get_profile_settings(self):
    profiles = self.settings_try_new("org.gnome.Terminal.ProfilesList")

#        if profiles:
#            default_path = "/org/gnome/terminal/legacy/profiles:/:" + profiles.get_string("default") + "/"
#            settings = Gio.Settings.new_with_path("org.gnome.Terminal.Legacy.Profile",
#                                                  default_path)
#        else:
#            settings = Gio.Settings.new("org.gnome.gedit.plugins.terminal")

    settings = Gio.Settings.new("org.gnome.gedit.plugins.terminal")
    return settings

Once you restart, you should have a black and white terminal-

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .