0

I am saving data to tape with an LTO drive and have no problems with the majority of files. However, if I try to archive some disk image files (has occurred with iso & bin/cue) then I will get an error. For example:

$ tar -cvf /dev/st0 ubuntu-14.04.4-desktop-amd64.iso
ubuntu-14.04.4-desktop-amd64.iso
tar: /dev/st0: Cannot write: Input/output error
tar: Error is not recoverable: exiting now

In this case the ubuntu-14.04.4-desktop-amd64.iso file causes it to fail. If I run the same command but add in gzip compression tar -czvf /dev/st0 [...] it works just fine. Not all disk images have this problem though. The ubuntu-16.04.1-server-amd64.iso file transfers just fine without gzip.

I'm guessing that there is some kind of eof data inside the disk image causing it to fail. I have tried adding the -i flag to ignore those though,

-i, --ignore-zeros
ignore zeroed blocks in archive (means EOF)

but it doesn't help. Could it be a drive level eof in the data? Is there a best practice data sanitation that I'm missing?

Though gzip would work, when doing large arbitrary backups I'd rather not have to gzip all files to be sure that I don't encounter this problem. This would remove any advantage the the LTO compression and shift the load to the CPU.

6
  • Anything else logged into dmesg, kern.log, syslog or anywhere else?
    – rovr138
    Mar 9 '17 at 18:26
  • All three contain this message [ 3829.256866] st 16:0:3:0: [st0] Sense Key : Aborted Command [current] [ 3829.256886] st 16:0:3:0: [st0] Add. Sense: Information unit iuCRC error detected
    – AkBKukU
    Mar 9 '17 at 18:30
  • Actually it seems intermittent. I can run the command multiple times in a row and sometimes it works and other times it fails
    – AkBKukU
    Mar 9 '17 at 18:39
  • CRC is a error detection technique. It's having issues validating the files it's writing. It could be an issue with data, or it could be an issue with the tape or drive. I hope this helps a bit, but I don't have a test tape drive to test.
    – rovr138
    Mar 9 '17 at 18:42
  • Regarding data, maybe check if other people have had issues storing binary data and how they got around it.
    – rovr138
    Mar 9 '17 at 18:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.