0

I came across an error trying to install OpenCASCADE (oce) using cmake, where I was following the build command:

mkdir build
cd build
cmake -DOCE_INSTALL_PREFIX=/path/to/where/you/want/oce ..
make install

I downloaded OpenCASCADE with: git clone git://github.com/tpaviot/oce.git from https://www.dealii.org/8.3.0/external-libs/opencascade.html

The command line build error is:

-- Build 64bit
CMake Error at /usr/share/cmake-3.5/Modules/FindPackageHandleStandardArgs.cmake:148 (message):
  Could NOT find OpenGL (missing: OPENGL_gl_LIBRARY OPENGL_INCLUDE_DIR)
Call Stack (most recent call first):
  /usr/share/cmake-3.5/Modules/FindPackageHandleStandardArgs.cmake:388 (_FPHSA_FAILURE_MESSAGE)
  /usr/share/cmake-3.5/Modules/FindOpenGL.cmake:172 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  CMakeLists.txt:440 (find_package)

I checked to see if I had a version of OpenGL, with,

glxinfo | grep "OpenGL version"

that showed:

OpenGL version string: 3.0 Mesa 12.0.6

So it seems I have OpenGL but the build cannot find it. Can anyone understand how to resolve this?

0

This question has been solved by installing a development version of OpenGL, following the link at:

How do I set up an OpenGL programming environment?

and installing the files: sudo apt-get install anjuta

sudo apt-get install freeglut3 freeglut3-dev libglew1.5 libglew1.5-dev libglu1-mesa libglu1-mesa-dev libgl1-mesa-glx libgl1-mesa-dev (includes opengl dev though under different names, as I undertstand it)

I also needed the development version of freetype by using:

sudo apt-get install libfreetype6-dev , from last comment at:

freetype cannot be found by build #3029

Now OpenCASCADE is building correctly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.