48

I am running Xubuntu 16.04.2 LTS with Xfce 4.12

I have customized the panel, but after saving the changes I got the message:

"Please restart the panel for visibility changes to take effect."

How can I restart the panel?

1
  • You could try rebooting
    – M. Becerra
    Mar 9, 2017 at 16:57

4 Answers 4

80

To restart the panel, open the terminal and run the following command:

xfce4-panel -r

Your changes should be visible now.


The -r option stands for restart, as described in the man page:

-r, --restart

Restart the running panel instance

5
  • 2
    In my case the -r only stopped and not started the panel :\ Could be me.. Sep 9, 2021 at 19:36
  • Works in Arch Linux with Xfce as well. Thanks.
    – Marcin
    Sep 27, 2021 at 2:33
  • 2
    For me, this made the panel vanish completely, and furthermore the panel configuration tool from the Settings Manager will no longer launch. (On 19.10 now.)
    – Pointy
    Oct 2, 2021 at 14:31
  • Worked for display problems in Linux Lite which internally uses xfce as DE
    – Cadoiz
    Sep 13, 2022 at 6:08
  • This also just made the panel disappear just now (and the process stop, as observed by ps). Nov 1, 2022 at 11:10
3

Sometimes I find that, xfce panel is gone. Therefore I need to restart the panel.

Above restart process do not work 100%. In my system, it cannot initialize session-buttons and other add-on(s).

To complete panel restart, just open the task manager and kill the xfce4-panel process. Don't worry. System will restart the panel just after is has been killed.

1
pkill xfce4-panel ; xfce4-panel &
0

If you think you'd be better off killing the panel process first, try this:

#!/bin/sh

panelcommand=$(ps aux | grep -e "xfce4-panel" | grep -e "--display" | awk '{print $11,$12,$13,$14,$15}')

ps aux | grep -e "xfce4-panel" | grep -e "--display" | awk '{print $2}' | xargs kill

$panelcommand

Works fine in Debian 07 (Wheezy).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .