I am using ubuntu 16.04. I want to disable the spinning down of hard disks. I do not see this option in the power management settings. Where can I find these options?

4 Answers 4


In "Disks" utility, choose your relevant drive, then press Ctrl + e to open Drive Settings, in Standby tab, you can edit standby timeout settings.

  • thanks. but it is not switched on. Does that mean it is disabled?
    – Ekoji
    Mar 9, 2017 at 11:09
  • if it's "OFF", your disk should not spin down - it's possible that your hardware is not properly supported :/ All I can think of is to use the Disks gui or hdparm to try and set your spin down time to some huge length so it's less of an issue.
    – kurja
    Mar 9, 2017 at 12:35
  • Drive settings do not seem to exist for external drives in 18.04 :/
    – oarfish
    Apr 29, 2019 at 19:23
  • Thanks for the answer, Linux GUI stuff should be reworked again, everything is everywhere... Nov 7, 2020 at 6:35

I am not aware of any GUI tools to do this, but I do not claim that such tools do not exist.

I use the program hdparm to configure this value.

sudo apt install hdparm

How can I control HDD spin down time? goes into more detail.

Sadly, some hard drive brands are not supported in hdparm. Most notably, certain generations of Western Digital Green and Blue drives require use of a proprietary DOS binary wdidle3.


After spending few hours of digging how to perform this in the best way, I want to share my findings.

Short guide how to set spin down time for Your disk:

go gnome-disk-utility in Your system, then select Your disk and leftclick in the right corner, select disk settings.

now in the first tab adjust the value.

The problem is, when you suspend your system and resume this stops working.

To get it working even after resume You need hdparm installed, so:

$ sudo apt install hdparm

now You have to create a script

case $1/$2 in
    echo "Going to $2..."
    echo "Waking up from $2..."
    hdparm -S 30 /dev/sdb

The most important line here is hdparm -S 30 /dev/sdb which defines 2minutes + 30 seconds spin down time for disk sdb. Now move script to /lib/systemd/system-sleep and give it executable rights `chmod a+x yourscriptname'.

Voila, now even after resume system will stop the disk.


Crucial SSDs do not like to be shut of, so I too am searching for the solution. I found this website, which seems to give the answer but is a little confusing:
Tune Your Hard Disk

My Ubuntu 16.04 reports my timeout is set to 254, which the article states is not used.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .