1

I've installed the Openstack-Base charm bundle with JuJu.

The documentation states: https://jujucharms.com/openstack-base/

Ensuring it's working To ensure your cloud is functioning correctly, download this bundle and then run through the following sections.

All commands are executed from within the expanded bundle.

What does this mean? Do I ssh into the nova compute controller? Which machine do we run the commands on?

I tried running this on the command in the nova cloud controller and got the following:

ubuntu@juju-9d518a-1-lxd-1:~$ sudo apt-get -y install python-novaclient python-keystoneclient python-glanceclient python-neutronclient
Reading package lists... Done
Building dependency tree
Reading state information... Done
python-keystoneclient is already the newest version (1:2.3.1-2).
python-neutronclient is already the newest version (1:4.1.1-2).
python-glanceclient is already the newest version (1:2.0.0-2ubuntu0.16.04.1).
python-novaclient is already the newest version (2:3.3.1-2ubuntu1).
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
ubuntu@juju-9d518a-1-lxd-1:~$ source novarc
-bash: novarc: No such file or directory
ubuntu@juju-9d518a-1-lxd-1:~$

Not sure what to do here as the guide is not too specific.

EDIT 1: I've searched for how to work with openstack CLI and found some nice information. I installed the openstack cli on a new server running ubuntu, you can install it even on the same node as you installed juju. The way to get it working is to go into the openstack horizon dashboard, go to Project -> Compute -> Access and Security

the url is: http://enter_your_horizon_ip/horizon/project/access_and_security/

From here you can click on the Download Openstack RC File. Save the file, then upload it to the server in which you installed the openstack cli tools.

Once inside that server, run the command to change the source to the rc file like this:

im my example, the rc file name is example_rc.sh

source example_rc.sh

you will be prompted for a password, this the same password that you used to login to horizon dashboard.

once this is done, you will be able to start using the openstack commands.

NOW: I'm stuck on something else, still related to steps taken after the guide:

The setup guide says the following:

Configuring an image

In order to run instances on your cloud, you'll need to upload an image to boot instances from:

Configure networking

For the purposes of a quick test, we'll setup an 'external' network and shared router ('provider-router') which will be used by all tenants for public access to instances:

> ./neutron-ext-net -g <gateway-ip> -c <network-cidr> \
>     -f <pool-start>:<pool-end> ext_net

Which unit are we running this from?

I have a feeling that the "source novarc" was crucial to this, but where to get the source novarc?

I tried running these commands form the neutron instance as well as the controller instance, and I get the following errors:

root@juju-9d518a-1-lxd-1:~# ./neutron-ext-net -g 10.230.168.1 -c 10.230.168.0/21 \
>     -f 10.230.168.10:10.230.175.254 ext_net
bash: ./neutron-ext-net: No such file or directory
root@juju-9d518a-1-lxd-1:~#

Where are these bash files? Where is the novarc file?

Would be helpful if the documentation specified this.

Thanks for reading, hope you can help!

1

You'll need to download and extract the bundle zip file using this link - the novarc and helper tools are co-located with the bundle in the charm store.

  • Thanks for letting me know James. It turns out that, because I actually used the JuJu GUI instead of the CLI from the start, I was not aware of the extra tools and the very essential "novarc" file. I will be re-installing, this time using the CLI. If I can get everything to work I will post a link here to a detailed explanation of my endeavor, as this might help someone else who blindly followed the GUI like me :) – Oscar Mar 11 '17 at 9:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.