2

I am using Ubuntu 14.04LTS on a thinkpad with an intel integrate card and a nvidia card.

Everything is fine with nvidia-304 or nvidia-340. However, every time I install newer nvidia driver such as nvidia-352, nvidia-361 or nvidia-367, I would be greeted with a black screen after reboot. I can hear the greeting sound of ubuntu, but cannot see anything. Then I have to remove the nvidia drivers.

All the commands are:

sudo apt-get install nvidia-version

sudo apt-get remove nvidia* --purge 

Why is this happening? Are there any methods to prevent this problem? Any help would be appreciated!!

Update:

I installed nvidia-375 but was still greeted by a black screen.Then I installed nvidia-prime and insert the command 'prime-select intel'. Then the black screen has gone. But it seems that it simply avoids using the nvidia driver and card instead of solving the real problem. Even if it works, as I prefer bumblebee, I think installing nvidia-prime is not the best solution.

P.S.

I have found some answers about how to fix the black screen problem, but none of them can help me install newer version of nvidia driver.

Some other information:

lspci |grep 3D
01:00.0 3D controller: NVIDIA Corporation GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M]
  • "Everything is fine with nvidia-304 " - there may be no advantage of installing a newer driver. – Takkat Mar 9 '17 at 9:24
  • It depends on the model of GPU you have. Older GPU's are not supported by newer drivers, as they don't have the features of the newer chips. If your GPU is a bit older, you will get everything you need form 340. Unless you face issues with 340, there is nothing you would get from updating the driver. In short, 340 is fine and modern and should fully support your chip. – Mark Kirby Mar 9 '17 at 12:44
  • @Takkat The nvidia-304 and nvidia-340 were OK but when I installed cuda-8.0 and run ./deviceQuery, it told me that 'CUDA driver version is insufficient for CUDA runtime version'. I looked up several instructions and their advice are to upgrade nvidia driver. Therefore I met this problem. – Schur Von Mar 9 '17 at 23:52
  • @MarkKirby How can I know which nvidia driver is suitable for my GPU? – Schur Von Mar 10 '17 at 0:00
  • nvidia-304 driver is not compatible with CUDA. In order to avoid this incompatibility, when you install CUDA it automatically installs the compatible Nvidia driver along with it. – karel Mar 10 '17 at 7:12
0

I had nvidia 378 when I tried to install CUDA 8.0 and during the install process my drivers got downgraded to 375.

This is the process I followed to install them (taken from my notes so I can re-install faster if needed). As mentioned by Mark Kirby do not use xorg ppa.

### Add nvidia drivers
sudo add-apt-repository ppa:graphics-drivers/ppa
# More Info on https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa
sudo apt update
sudo apt-get install nvidia-378

You will have to research the dependencies between your graphic card, CUDA versions and the software for which you need CUDA. Hopefully you 'll be able to find a sweet spot where all can live together.

P.S. My GPU is nvidia 1050Ti so nvidia-378 was fine (but CUDA still downgraded it). For your graphic card 375/378 may not work (as you already experienced issues).

edit: You didn't mention if you tried nvidia-375 in your post. If not give it a try to see if it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.