12

Title says it all.

Instead of popping out in front of all the open windows, the task switcher is stuck in the back. At first, I thought it just didn't work - and then I closed some of the windows, I saw it was just kinda stuck in the back.

Screenshot of switcher behind an application window in Ubuntu 16.04

EDIT 07.12.2017: Tried the fixes in the comments and answer below, no cigar.

  • Do you have clean Ubuntu 16.04 installation? – j123b567 Apr 2 '17 at 13:27
  • @j123b567 that I do indeed. Also, that's a catch-all. Try something more specific if you may:) – t0mgs Apr 3 '17 at 15:30
  • Can you please add a screenshot? – rubo77 Apr 4 '17 at 11:47
  • 2
    askubuntu.com/questions/214060/… this may work for you ! – Ali Razmdideh Apr 6 '17 at 11:07
  • I've just started getting this same problem, a screenshot is tricky - as alt+printscreen whilst already holding alt+tab behaves a bit strangely. – Andrew M Nov 23 '17 at 13:47
4

I solved it by using CompizConfig Settings Manager. Go to Window Management and enable Application Switcher. By doing so I got a popup telling me that there were conflicting bindings with another plugin. Click Resolve conflicts, and set x anyway on the following dialogs.

| improve this answer | |
1

I don't know the cause - but a reboot fixed it for me. I'm sure lighter-weight solutions must be possible.

Looking forward to someone providing a better answer.

| improve this answer | |
1

I've seen this issue several times, including just this morning.

Based on the discussion here: https://ubuntuforums.org/showthread.php?t=1860967, I tried unity --replace from the command line.

The good news is that it fixed the issue; the bad news is it's only a bit less drastic than logging out or rebooting; it immediately killed almost all my GUI apps (only gedit and the terminal window remained).

Incidentally, there was a somewhat nonsensical message in the terminal: WARNING: This is for compatibility with other desktop interfaces please use unity without --replace.

I have no idea what that means, or what we should type instead. But this command did put my task switcher back on top.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.