7

Mozilla announced that NPAPI will not be supported since the released version 52. This means that Java will not be supported either.

Chromium based browsers do not support java for some time already.

At java.com they suggest using Internet Explorer or Safari.

I am using a Java app to sign banking documents. Is there any way to use Java in Ubuntu?

  • will firefox esr work for you? ff esr 45.x.y is supported till june 13 2017 – Manoj Sawai Mar 9 '17 at 17:50
4

The Java Runtime Environment (JRE) is still available for Ubuntu; it's provided by a third part repository with package name update-sun-jre. This obviously won't work for in-browser use when the browser has dropped the API it uses, but if your signing can be done offline, this will likely solve the problem for you.

Otherwise, you may wish to examine the reasons Mozilla gave for dropping NPAPI -- which all boil down to security. Flash and Java, the main users for that API, are both security nightmares, and the trend in browser design has been for several years to move away from those helpers to XML and HTML5 to do the same jobs. It may be a good plan to ask your bank when they'll be updating to more secure tools, or how you can assure the security of your connection to them if they insist on using outdated tools.

Another possibility, though I don't know how long it will remain viable, is to switch to the SeaMonkey browser. It's Firefox under the skin, but it looks like the old Netscape Internet Suite -- and, at present, still supports Java (and flash, via pepperflash-plugin). It has generally been a couple versions behind Firefox, so it may gain you some time for a better solution.

The last, and IMO worst option would be to use Wine to install and run Internet Explorer -- but I'd avoid even mentioning that this is possible when discussing this security issue with your bank.

  • I can't sign it off-line. That's the problem. – Pilot6 Mar 8 '17 at 17:38
2

I stumbled upon the same issue and couldn't afford not running Java for my online banking.

I installed Seamonkey 2.46 (64 bits) in a separate folder and it worked fine. It feels like browsing in the 90's though.

0

You can temporarily reenable NPAPI support by this procedure:

But there is a way to enable Java, Silverlight etc NPAPI plugins in Firefox 52 using an about:config setting. Add new Boolean string "plugin.load_flash_only" and set it to false. Then restart the browser.

Source

  • I tried it, but it did not work. – Pilot6 Mar 9 '17 at 19:58
  • Sorry. I have no way to test it. Comments on the reference page said it worked. – Organic Marble Mar 9 '17 at 22:47
  • That was the first I've tried ;-) – Pilot6 Mar 9 '17 at 22:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.