8

First of all, I checked "How to prevent my screens from turning off, when the screen is locked?" but that didn't help.

The laptop is set to not suspend no matter if it's running via battery or AC. Under "Brightness & Lock", the option "Turn screen off when inactive for" is set to "Never". Brightness is set to 100% and dimming is enabled.

When I lock the machine however, the display fades to blank and then the screen goes off. How do I prevent this?

3

Quite by accident tonight I discovered a "hack". Enter an invalid password at the lock screen and it will stay there and not fade to black.

I'll be using this technique myself from now on until a better answer comes along. The duplicate candidates don't work for me under Ubuntu 16.04 and like yourself it irritates me the screen turns off.


Feb 20 2018 Update - Disable Dimming CLI method

To prevent screen from turning off you need two settings, one under battery power the other when plugged into wall outlet (A/C).

For battery timeout:

gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-battery-timeout <time_in_seconds>

For AC timeout:

gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-ac-timeout <time_in_seconds>

So for both Battery and A/C set the time to 0 (never).

For Login screen:

gsettings set org.gnome.desktop.screensaver idle-activation-enabled false

Disable dimming screen when idle:

In Unix & Linux someone complained when on battery screen dims every 20 seconds and wants to turn that feature off:

gsettings set org.gnome.settings-daemon.plugins.power idle-dim false
|improve this answer|||||
  • 2
    Unfortunately, this solution does not work on Ubuntu 18.04 LTS. – Michał Szczech Oct 4 '18 at 6:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.