I know this topic is all over the web, but none of the solution I've found solved my problem.

I want to install ubuntu 16.04 LTS in dualboot mode onto a new computer (Lenovo Yoga 910, intel i7-7500u, UEFI and SSD) along side Windows 10.

I configure a USB drive to a .iso with the 64bit version of Ubuntu 16.04 LTS. I disabled fastboot, my ssd drive is in "basic mode" and I shrunk the Windows volume. There is now, 6 different parts in my SSD :

  • Partition of EFI system (260mo)

  • Windows (C:) 96.95 Go (NTFS)

  • Data (E:) which I created to store data that will be both used in Windows and Ubuntu 254 Go (NTFs)

  • Lenovo (D:) 25 Go (i don't know what it s for but it was there at the beginning)

  • A back up of 1000mO

  • And finally a non allocated space of 97 Go that I dedicate to the (hopefully) coming Ubuntu environment.

I then reboot holding f12 to boot from the USB key, I then choose the option "install ubuntu".

1) I choose English then hit Continue

2) I don't connect to wi-fi

3) I don't tick anything in preparing to install ubuntu.

And then I would expect to get the window : enter image description here

But I don't. I directly get to the second window "Installation type" with the list of device on which I could install ubuntu. And there I only got one device named /dev/sda (which by the way is the same name as the "device for boot loader installation" : /dev/sda Kingston DT, which I found weird). I expected to see the 6 disk partitions I mentioned earlier.

I read the answer : How can I dual-boot Windows 10 and Ubuntu on a UEFI HP notebook? But it doesn't apply to me. As well as this tuto : http://linuxbsdos.com/2013/03/12/dual-boot-windows-8-and-ubuntu-12-04-in-uefi-mode/

It is now a day I am on this question... Does anyone know what can I do from there ? Thanks a lot.

  • Is your model like this? Warning: Microsoft Signature PC program now requires that you can't run Linux. Lenovo Yoga 900 ISK2 UltraBook Sept 2016 ubuntuforums.org/showthread.php?t=2337719 After the major flap, Lenovo did release new UEFI for some Yoga models that fixed issue. Have you updated UEFI to newest available? – oldfred Mar 9 '17 at 16:54
up vote 2 down vote accepted

I directly get to the second window "Installation type" with the list of device on which I could install ubuntu. And there I only got one device named /dev/sda (which by the way is the same name as the "device for boot loader installation" : /dev/sda Kingston DT, which I found weird). I expected to see the 6 disk partitions I mentioned earlier.

The /dev/sda device you're seeing sounds like your USB flash drive, on which the Ubuntu installer itself resides. The symptoms you're reporting are usually the result of Ubuntu being unable to read your hard disk, which in turn usually means that the disk type or disk controller is not supported by the kernel you're using. If I'm right, there are several options for how to proceed:

  • Since Ubuntu 16.04 and 16.04.1 use an older kernel, you may need to upgrade to a newer kernel by using Ubuntu 16.04.2, Ubuntu 16.10, or even a pre-release version of Ubuntu 17.04.
  • If none of these versions work, then you could try another distribution (something unrelated to Ubuntu -- Fedora, OpenSUSE, or Arch might work; but don't bother with the likes of Mint or ElementaryOS, since they're based on Ubuntu).
  • Another option is to install Ubuntu on an external USB drive. You'd need to use this drive for your shared NTFS partition, too.
  • You could run Ubuntu in a virtual machine (VirtualBox, VMware, etc.) running under Windows.
  • If the computer is new enough, you could return it to the store for a refund and get something else; or even if that's not an option, you could sell it and buy something else. In either of these cases, you should obviously be more cautious about compatibility. You might want to consult the Ubuntu certified hardware page to be sure you get something that works with Ubuntu.
  • 1
    It really sounds like my issue indeed. It's a really new computer and it is NOT in the Ubuntu certified hardware page, I'll try different version of Ubuntu and let you know what is happening. Thank you for this very cogent help. – probaPerception Mar 9 '17 at 17:27
  • I tried 16.04.1, 16.04.2, 16.10, 17.04 and none of these releases work for Lenovo 910. There is a solution that I found on the web that apparently works : it is to change RST to AHCI in BIOS, and fresh install windows (download essential drivers before installing), then install linux. I personally will not to this because my computer is new enough to be returned to the store... I just thought this solution may be of interest for some of you. cv : forums.lenovo.com/t5/Linux-Discussion/DualBoot-on-Yoga-910/td-p/… – probaPerception Mar 9 '17 at 22:12
  • That page makes it sound like, from a Linux/Ubuntu perspective, it's just a matter of changing that one firmware setting. That part should be pretty simple. Getting Windows to accept such changes can be trickier, and is beyond the scope both of this site and my own knowledge, but it can probably be done without re-installing Windows. If you decide to pursue this option and it works, I encourage you to write it up as a new answer and accept it instead of mine. – Rod Smith Mar 10 '17 at 2:31

There is no need of EFI partition as Ubuntu16.0.4 supports legacy mode also. When we install Windows 10 then it usually takes 2 drives. First one is of 500mb to boot and second one contains main windows files. After installing windows 10 create 3rd drive (file system ext4) for Ubuntu next to windows drive. Ubuntu takes about 10 gb to install. So I think it will be wise decision to give it more than 20 gb. After this we create 4th drive (Linux swap) for swapping which is mandatory for hibernating and increasing performance. Its size is dependent on ram and should be more than the size of total ram.

Now when you will run ISO, DVD or USB of Ubuntu installation in legacy mode it will give you first option to install Ubuntu with windows 10 to create dual boot. As you will enter in that option, a clear message will appear only 3rd and 4th drive will be reformatted. Go next, next and install Ubuntu. At the end you will see Dual boot system has been created.

Use "Gparted partition editor" to modify partitions which is already present in "Test mode of Ubuntu" (Live Cd mode) in same setup which you will run to install it.

  • Thanks Alamjit. I tried to do what you say (including booting in Bios mode instead of EFI), but I did not find out how to "mount" a new drive with "/" prefix. I did configure different drives as you described (including a SWAP and a ext4). However, the issue is when I boot from the USB with the .iso file. Then, it is as if I only have one drive (dev/sda/ of a size of 56Go which is not not any of the drive I created). There is no other drive when I try to install. – probaPerception Mar 8 '17 at 18:37
  • 1
    Did you use Gparted partition editor ? – Alamjit Singh Mar 9 '17 at 3:05
  • Yes, I used Gparted but Gparted only detects a drive called dev/sda which is 56Go (my drive is 500Go and the partition I "tried" to allocate to Ubuntu is 100Go, so I really don't know what is this 56Go sda/dev/. Moreover, I have this error in gparted : “physical block size is 2048 bytes, but Linux says it is 512”. I have something very similar to this issue : askubuntu.com/questions/781223/… I believe, the only drive detected is the USB (16go that become a 64go because of the block error). – probaPerception Mar 9 '17 at 8:39
  • 1
    upload screenshot of "Gparted parition editer" view, it will be more helpful to find out problem for other. You simply need ext4 and linux swap partition. So ubunto setup will automatically detect them. – Alamjit Singh Mar 9 '17 at 15:01
  • 1
    Thanks Alamjit, but the problem is that my Hard Drive is not recongnized because of the very recent feature of the Lenovo 910 hard drive. – probaPerception Mar 9 '17 at 22:17

Whenever I create Dual-Boot Windows 10 and Ubuntu 16.04 systems here is what I do. This might be a problem for you if you need to preserve the Windows 10 partition at all. You also need to have an iso image of Windows 10 on a bootable USB.

  1. Install Ubuntu first and let erase the disk as you showed in your screenshot. This gives grub the boot manager duties for the system.
  2. Partition the disk using gparted in Ubuntu and setup the Windows NTFS partition to whatever size you want.
  3. Boot to your USB stick with the Win10.iso and install Win10 pointing the install to the partition you created in step 2. Complete the Win10 install. (It will take over the boot manager from grub.) Win10 should be happily booting on your system.
  4. Boot to your USB stick with the Ubuntu Live iso image on it. DO NOT INSTALL UBUNTU AGAIN. Just pick "Try Ubuntu"
  5. Follow this link for boot-repair instructions. https://help.ubuntu.com/community/Boot-Repair
  6. You will now have a "Windows 10 /dev/XX" (XX=your Win10 partition) selection on the boot menu.
  • Ubuntu's GRUB normally takes over the boot manager duties when you install it after Windows, so most people recommend installing Ubuntu second; that obviates your steps 2-5. Also, Boot Repair completely re-installs GRUB, which is overkill and runs a (very small) risk of creating new problems. Instead, if you must re-install Windows after Ubuntu, I recommend using EasyUEFI in Windows to make Ubuntu's GRUB the default boot manager. (This approach works only on EFI/UEFI-based computers, though.) – Rod Smith Mar 9 '17 at 19:54

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.