I am using Virtual Box 5.1 on top of Windows 7 Host OS with Ubuntu 14.04 LTS Guest OS. I have already installed VBOXADDITIONS_5.1.14_112924 and restarted the Guest machine. The folder appears as mounted underneath the Devices in Files, and it appears as shared on the Host machine.

What permissions do I need to change on my Host/Guest OS to make this shared folder work?

2 Answers 2


You have to add yourself to the shared folders group in the Ubuntu guest.

sudo adduser $USER vboxsf

Guest OS needs to be restarted after this.

  • 18
    Worked for me but required a reboot to the guest VM first.
    – Itay
    Jul 27, 2017 at 8:01
  • 7
    It worked for me after logout and login again only.
    – Gopal00005
    May 14, 2019 at 15:30
  • 8
    Note: No need to replace $USER with anything, the string needs to be input exactly.
    – zeitgeist
    May 19, 2021 at 12:45
  • 3
    Worked for me on Ubuntu 20.04. Thanks a fortune!
    – Joseph
    Jan 29, 2022 at 19:41
  • 6
    still relevant in 2022
    – petrosmm
    Apr 21, 2022 at 19:48

If you get

'Username' is not in the sudoers file. This incident will be reported

then use

su root 

then you can proceed with as suggested by Bora.

sudo adduser $USER vboxsf

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .