7

My computer has Ubuntu 16.04.2 LTS 64-bit and Firefox 52 64-bit.

For one of the government web sites, because it is using browser Java plugin to sign documents, I need to install:

  1. Firefox ESR 52. Ordinary Firefox 52 does not support Java as browser plugin anymore, because NPAPI was removed (source).
  2. Firefox ESR 52 32-bit. I know for sure Firefox 32-bit only supports Sun Java on Windows, but not sure if this is also a limitation on Ubuntu. If it is, I need Firefox 32-bit version and not Firefox 64-bit version. 2

I know I can install Firefox 32-bit like using:

  1. install Firefox 32-bit in terminal:

    sudo apt install firefox:i386
    

    but installing Firefox 32-bit will uninstall Firefox 64-bit, which I would like to keep.

  2. download and extract Firefox 52 ESR 32-bit from 2.

Is there any other was to install Firefox ESR 52 32-bit and also install Sun Java 32-bit on Ubuntu 16.04.2 LTS 64-bit without uninstalling Firefox 52 64-bit?

See:

  1. Plug-in support has been dropped other than Flash
  2. Download Firefox Extended Support Release

Thanks

  • If you do not want to use apt, or download it, then you would have to compile from source. What is wrong with downloading and extracting ? – Panther Mar 7 '17 at 18:12
  • It is not so simple. When downloading and extracting Firefox 32-bit it does not work on 64-bit linux. Optimal way it would be installing just some 32-bit libraries instead of installing Firefox 32-bit from repository. Do you know which of the packages (32-bit libraries) should be installed. – folow Mar 8 '17 at 15:52
8

Please try this workaround. For me, the plugins like Java and VLC came back after doing this. I'm using Ubuntu 16.04 64 bit with Mozilla Firefox 64 bit version 52 (not ESR) and Java JDK 1.8.0_112

  1. Open Firefox and type about:config in address bar and press enter
  2. Click 'I accept the risk!'
  3. Right click anywhere and select New>Boolean
  4. Type plugin.load_flash_only in the box that appears
  5. Set the value to false
  6. Clear all history and restart Firefox

I'm also using various Government websites which uses java plugin and Digital Signatures.

Try this and let me know.

Edit: Mozilla Firefox 53 will remove the flag plugin.load_flash_only so that this workaround won't work anymore.

Pale Moon web browser team announced that they will continue the support of NPAPI plugins indefinitely. To install java plugin in Pale Moon, run this in terminal

sudo ln -s /usr/lib/java/jdk1.8.0_121/jre/lib/amd64/libnpjp2.so /usr/lib/mozilla/plugins/libnpjp2.so

I've tested java plugin in Pale Moon browser. 100% working.

  • Worked for me, for Juniper VPN which uses the Java plugin. – Simon Labrecque Mar 15 '17 at 15:34
  • Yes this worked for me as well, thanks very much for posting these steps. Didn't have to downgrade to 32-bit or ESR. – jerome Mar 15 '17 at 22:47
  • Unfortunately this is a temporary workaround until Firefox 53 comes out when that flag will be removed. – mcarans Mar 17 '17 at 15:53
  • Doesn't work for me: there is no plugin.load* property. There are various other plugin.* ones; but not this one. – GhostCat Mar 20 '17 at 10:08
  • Hi, GhostCat You have to add the property, if you don't have one. See the 3rd step I wrote. Cheers. – La Corazón Mar 26 '17 at 17:02
2

I use 16.04 LTS 64-bit
I download and unpack 64-bit Firefox (but older version - v.45) from here https://www.mozilla.org/en-US/firefox/organizations/all/
And after that I close my 'standard' previously installed Firefox and run 'firefox' file from extracted folder of version 45 archive.
So I open my site and successfully run Java application inside it.

P.S.
I also updated Java to have the latest version:

sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update
sudo apt-get install oracle-java8-installer
0

You could install a new version in a local folder (such as ~/applications/firefox_esr/), but you won't be able to run them simultaneously. From what I've read on Firefox website, the Linux version does not have the same limitation the Windows version has; so you better just use the ESR 64-bits.


I had a similar issue but the above wasn't enough to solve the problem with the Java plugin. If that is not getting you through, install SeaMonkey 2.46 (64-bits) and try again.

  • NPAPI plugin support will be removed from the next ESR version. So we better find another solution. I will try SeaMonkey. – La Corazón Apr 17 '17 at 18:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.