5

I bought an Asus X550VX laptop a few weeks ago and installed Ubuntu 16.04 alongside Windows 10 on it. For a week or so everything worked fine, until one of the USB 3.0 ports stopped working. Soon after that, the other port stopped working too. The one USB 2 port still works fine. When I connect my phone to a USB 3 port it charges, but Ubuntu doesn't recognize that a device is connected. My wireless mouse doesn't work either on those ports.

I've googled around but nothing seems to help. I've updated my bios and added a "pci=nomsi" line to grub file. Any other suggestions?

  • Try unplugging everything and trying one device / cable at a time. – WinEunuuchs2Unix Mar 7 '17 at 18:12
  • Tried that and nothing works. Not my phone, mouse or flash drive. – LaTeNaaTToRi666 Mar 7 '17 at 18:31
3

This ought to do it:

  1. sudo gedit /etc/default/grub
  2. Find this line: GRUB_CMDLINE_LINUX=""
  3. Change it to GRUB_CMDLINE_LINUX="iommu=soft"
  4. Save
  5. Reboot
  • Works perfectly! – Rushat Rai Jun 30 '18 at 12:01
  • Worked perfectly in Ubuntu 18.10 – Abdul Rauf Feb 22 at 16:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.