5

Unable to create VPN connection as the Save button is always disabled.

relevant screenshot

Also, the Add VPN Connection... option under VPN Connections is disabled.


As per this solution, I tried accessing the nm-connection-editor from the terminal but the problem remained the same. Running the following:

$ sudo nm-connection-editor

Gave me the following error in the terminal:

** Message: vpn: (openvpn,/usr/lib/NetworkManager/VPN/nm-openvpn-service.name) file "/usr/lib/x86_64-linux-gnu/NetworkManager/libnm-vpn-plugin-openvpn.so" not found. Did you install the client package?
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
** Message: Cannot save connection due to error: Editor initializing...
** Message: Cannot save connection due to error: Invalid setting VPN: IPSec gateway

I checked org.freedesktop.NetworkManager.policy file as per this solution but the allow_inactive was already set to yes.


How can I resolve this issue? Is there any other way to connect to VPN?

  • If you don't mind using other tools, I had similar problems and openconnect worked for me – Katu Mar 7 '17 at 14:49
  • @Katu How can I install that? And, will it be useful in my case? Also, I need to mention this, the vpn client that we use in windows is GlobalProtect. I didn't find any alternative for that in linux. – UrsinusTheStrong Mar 7 '17 at 15:22
3

I had a similar problem. There was also no file "/usr/lib/x86_64-linux-gnu/NetworkManager/libnm-vpn-plugin-openvpn.so". The installation of the "network-manager-openvpn-gnome" package helped.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.