2

OS: Xubuntu
Original Kernel version: 4.4.0
New Kernel version: 4.1.3

I recently compiled a patched kernel. The details of the patch and installation procedure are here: https://wiki.litmus-rt.org/litmus/InstallationInstructions

It's a real-time patch for linux kernel 4.1.3. After patching, I installed the kernel on Xubuntu 14.04 with kernel 4.4.0. After installing the patched kernel, there seems to be an issue with the Policy Kit.

Complete /var/log/syslog of a boot here: http://pastebin.com/DbLxMpW7

Trying to start polkit

enter image description here

dbus:

enter image description here

Issues:

Doesn't let me install softwares

enter image description here

Doesn't automatically mount disks without root permission

enter image description here

Asks for password for log out/shutdown

enter image description here

When I boot from the original Xubuntu kernel, all of these issues dissapear. Have I done anything wrong during kernel compilation? Was there some option in make menuconfig that was wrongly set?

I don't suspect it's the problem arising from the patch, since, I downloaded the VM Image supplied here: http://www.litmus-rt.org/tutorial/vm-setup.html which had the patch already installed and there none of these issues present.

0

If your packages are all up to date, you can try an old bug fix for this assuming you're using lightdm.

Edit the file /etc/pam.d/lightdm

At the bottom, add

session required pam_loginuid.so
session required pam_systemd.so

This works in some 14.04 distros. If not, the alternative that has also worked for some is to remove apparmor:

sudo apt-get remove apparmor -y

But that's only a solution if you don't depend on apparmor for security.

  • Tried it. Unfortunately, neither of them worked for me. – Neil Patrao Mar 13 '17 at 17:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.