1

I installed QtCreator 5.8 by download Qt.run file(Qt 5.8.0 for Linux 64-bit) from Qt offical site( http://www.qt.io/download-open-source/#section-2).

I installed by command line(sudo ./qt.run).Installation done successfully.

When i tried to open qt-creator from command line.

ERROR:
./qtcreator: symbol lookup error: /opt/Qt5.8.0/Tools/QtCreator/lib/Qt/plugins/platformthemes/libqgtk3.so: undefined symbol: g_type_ensure.

Host : ubuntu 12.04.

  • Please edit your question and describe how you installed QtCreator. – Carl H Mar 7 '17 at 11:09
  • @cal H. Problem solved. I download qt-sdk package through synaptic.Then it starts working – Ravi sankar Mar 8 '17 at 10:17
2

This is just a platform theme, simply delete the file /opt/Qt5.8.0/Tools/QtCreator/lib/Qt/plugins/platformthemes/libqgtk3.so and it should start.

You will have to tackle another problem regarding "/usr/lib/x86_64-linux-gnu/libstdc++.so.6: version 'GLIBCXX_3.4.18' not found", which can be solved by installing this ppa:

sudo add-apt-repository ppa:ubuntu-toolchain-r/test
sudo apt-get update
sudo apt-get install libstdc++6-4.7-dev
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.