0

This question already has an answer here:

Edited to clarify the issue: New install of Ubuntu 16.04, and I recognized the wireless network option never showed up. Clicking on the Networking icon at the top, I'm given a greyed-out line saying "No network devices available". According to Pilot6 below, the drivers have been installed properly, so I can't say exactly what the real problem is.

Under my first assumption that the driver installation was the problem, I did a lot of searching around, mostly returning to this forum specifically, trying to find an answer. Most of what I've been doing has been trying to follow this: Installing Broadcom Wireless Drivers

So far, no luck. I followed the top answer, to the best of my abilities, and nothing seems to have worked. So I ran the install again, this time tethered to an internet connection. Next, I found a Linux driver on the Broadcom website; after some searching around to figure out how to properly use a tarbell, I've been continually returned an error following any make commands.

I'm not sure where to go next, or even what information to supply here. I'm a new user with little understanding of what exactly I'm doing, so patience is appreciated. Working between two computers, to prevent burning through data, but I will do my best to edit in any requested information as quickly as possible.

It is entirely possible that I've simply completely missed something basic. Here's what I've gathered that seems relevant or important:

lspci gives me: 01:00.0 Network controller: Broadcom COrporation BCM 43142 802.11b/g/n (rev 01)

Using lspci -nn -d 14e4: I gather the PCI ID is [14e4:4365] (rev 01)

rfkill list all only gives me information on the Bluetooth connection, which isn't blocked.

UEFI boot mode was brought up during installation, turned off Safe Boot.

Nothing else has been run during this install, except the attempt at installing the driver directly out of the tarbell that Broadcom offered.

Thank you in advance, any help or advice is greatly appreciated.


Edits: Output of lspci -knn | grep Net -A3:

            01:00.0 Network controller [0280]: Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365] (rev 01)
                Subsystem: Hewlett-Packard Company BCM43142 802.11b/g/n [103c:2230]
                Kernel modules: wl

/etc/network/interfaces text file contains the following:

            # interfaces(5) file used by ifup(8) and ifdown(8)
            auto lo
            iface lo inet loopback

marked as duplicate by karel, Eric Carvalho, Community Mar 13 '17 at 2:08

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Please edit your question and add output of lspci -knn | grep Net -A3 terminal command. – Pilot6 Mar 7 '17 at 11:15
  • The driver is installed correctly. – Pilot6 Mar 7 '17 at 18:42
  • Hovering on the networking icon at the top, it tells me there are "No network devices available" – R. Jasper Mar 7 '17 at 18:43
  • It is hard to tell what did you break when trying to install drivers. What is in your /etc/network/interfaces? – Pilot6 Mar 7 '17 at 18:45
  • Assuming you mean the text file: # interfaces(5) file used by ifup(8) and ifdown(8) auto lo iface lo inet loopback – R. Jasper Mar 7 '17 at 18:46
0

UPDATE: SOLVED

I decided to return to Installing Broadcom Wireless Drivers and take a look at a couple of the other highly-rated answers. The second answer (https://askubuntu.com/a/38700/662449) worked for me. I bent around it a little, reinstalling bcmwl-kernel-source after the other operations. During my reboot, I also disabled Secure Boot directly from the UEFI menu. Logging into the account, I am now connected to my home network.

Thanks again to Pilot6 for trying to help me solve the issue!

Not the answer you're looking for? Browse other questions tagged or ask your own question.