1

I updated today, and now bind9 won't start.

[FAIL] Starting domain name service...: bind9 failed!
invoke-rc.d: initscript bind9, action "start" failed.
dpkg: error processing bind9 (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 bind9
E: Sub-process /usr/bin/dpkg returned an error code (1)

I tried dpkg-reconfigure, with the following result:

/usr/sbin/dpkg-reconfigure: bind9 is broken or not fully installed

Tried removing, reinstalling, also tried dpkg --configure -a and apt-get install -f

How can I fix this, or where do I start looking for a solution?

1
  • Can you look in /var/log/apt/history.log for today's entries and see what might have affected it? Mar 6, 2017 at 20:23

1 Answer 1

1

I found the problem. It was a misconfigured zone file. But it wasn't one I would have expected, it ended in .zone.save extension. I deleted that file, and that seems to have solved that problem.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.