0

My space bar is not working. using external keyboard, which is really hard. Please advice me on mapping space key to alt key left or right in normal mode(I dont understand command prompt). Thanks in advance.

2

Try the XKB extension. Go onto your terminal and type:

sudo nano /usr/share/X11/xkb/symbols/

The terminal will ask you for your passwor(Linux does not display your typing in terminal when entering a password, don't worry, it is entering the text!)

You should now see a list of keys and there corresponding values

(ie. key <ALT> { [ Alter ] };) Keep scrolling down until you find the ALT option. Rename the corresponding value, in this case Alter, with "Space". Press CTRL+O and then CTRL+X Hope this helps

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.