I have Ubuntu 16.04 installed as command line and a week or two ago wanted to try using KVM. As a part of the KVM install using

sudo apt-get install qemu-kvm libvirt-bin virtinst bridge-utils cpu-checker

A couple days ago, I wanted to install the Ubuntu GUI and ran the following:

sudo apt-get install ubuntu-desktop

All is working good with regards to the Ubuntu GUI however, when I start up Ubuntu, on the main login screen there is a login for me and then there is one for "Libvirt Qemu" listed (as well as "Guest Session"). Am I correct in assuming that "Libvirt Qemu" is some sort of default user for the KVM isntallation? it asks me for the password for that account but I have no idea what it is or how to figure out what it might be


Update This solution is for LightDM (default display manager up to Ubuntu 16.04 LTS), not for GDM (default display manager in newer Ubuntu versions).

It's a bug

The bug is described and discussed here, in Ubuntu Launchpad.


Shortly, there are four kind of users in Linux: root (UID 0), system users (low UIDs), regular users (high UIDs) and the nobody user (UID 65535, the last UID).

The Ubuntu login screen uses a service called Accountsservice (a lightdm component) that, by default, presents all the regular users in the login screen.

However, the current Libvirt/QEMU package for Ubuntu 16.04 uses a high UID for the user libvirt-qemu. It seems to be a bug (system packages usually creates system users, with low UIDs).


Each regular user can also set custom options to it's login process (background image for the login screen, desktop environment - Gnome or KDE, etc). These options are saved in /var/lib/AccountsService/users.

Using these custom options, it's possible to mark a regular user as a system user to Accountsservice. So, Accountsservice will consider it a system user despite it's UID.

To do this to the libvirt-qemu user:

echo -e "[User]\nSystemAccount=true" > /var/lib/AccountsService/users/libvirt-qemu

After this, you should reset the Accountsservice cache:

service accounts-daemon restart

The previous commands should be run as root.

  • Thanks, but it didn't work for me. The user is still listed on the login screen!
    – Mehran
    Dec 23 '19 at 3:44

That appears to be a bug, I'm seeing the same thing after adding those same packages to a fresh 16.04.2 install. I'm fairly certain that "libvirt-qemu" is supposed to be a system account, not a user account; It shouldn't even be listed on the login screen in the first place.

My advice would be to ignore it until this gets fixed. Don't try to use or delete the account, you could accidentally break something.

  • Thanks Ethan, will keep an eye out and see if it goes away eventually with updates
    – jb61264
    Mar 16 '17 at 19:42
  • Would it be safe to delete the "libvirt-qemu" account after removing the thing that caused it to appear? In my case it is the gnome-boxes app.
    – geras
    Jan 10 '18 at 17:19

Not the answer you're looking for? Browse other questions tagged or ask your own question.