1

I use Ubuntu 16.04. I tried most methods and none are working. Please note I've used method that to remove Unity Tweak Tool, but it didn't work.

I always get this message and I've deleted most packages.

samerlol@SamerLOL:~$ sudo apt-get remove --auto-remove unity-tweak-tool 
[sudo] password for samerlol:  
Sorry, try again.  
[sudo] password for samerlol:  
Reading package lists... Done 
Building dependency tree        
Reading state information... Done 
Package 'unity-tweak-tool' is not installed, so not removed 
The following packages will be REMOVED:   
avahi-utils ethtool gir1.2-notify-0.7  
ippusbxd libandroid-properties1   
libappstream3 libhardware2 libhud2  
libhybris libhybris-common1 libmedia1   
libqt5feedback5 libqt5multimedia5 libqt5positioning5 libqt5quicktest5   
libqt5test5 libunity-action-qt1 libx86-1 plainbox-provider-checkbox    
plainbox-provider-resource-generic plainbox-secure-policy pm-utils    
pyotherside python3-checkbox-support python3-cups python3-cupshelpers   
python3-guacamole python3-jinja2 python3-padme python3-plainbox    
python3-pyparsing python3-requests python3-urllib3 python3-xlsxwriter   
qml-module-io-thp-pyotherside qml-module-qt-labs-folderlistmodel    
qml-module-qt-labs-settings qml-module-qtfeedback    
qml-module-qtgraphicaleffects qml-module-qtquick-layouts    
qml-module-qtquick-window2 qml-module-qtquick2 qml-module-qttest    
qml-module-qtwebkit qml-module-ubuntu-onlineaccounts    
qml-module-ubuntu-performancemetrics qmlscene  
qtdeclarative5-accounts-plugin   
qtdeclarative5-dev-tools  
qtdeclarative5-qtquick2-plugin   
qtdeclarative5-test-plugin  
qtdeclarative5-unity-action-plugin   
suru-icon-theme  
system-config-printer-common system-config-printer-udev    
ubuntu-core-launcher ubuntu-mobile-icons ubuntu-ui-toolkit-theme vbetool
0 upgraded, 0 newly installed, 59 to remove and 0 not upgraded. 
After this operation, 48.6 MB disk space will be freed. 
Do you want to continue? [Y/n] y 
(Reading database ... 264976 files and directories currently installed.) 
Removing avahi-utils (0.6.32~rc+dfsg-1ubuntu2) ... 
Removing ethtool (1:4.5-1) ... 
Removing  gir1.2-notify-0.7 (0.7.6-2svn1) ... 
Removing ippusbxd (1.23-1) ...  
Removing libhybris (0.1.0+git20151016+6d424c9-0ubuntu7) ... 
Removing libmedia1 (0.1.0+git20151016+6d424c9-0ubuntu7) ... 
Removing libhardware2 (0.1.0+git20151016+6d424c9-0ubuntu7) ... 
Removing libhybris-common1 (0.1.0+git20151016+6d424c9-0ubuntu7) ... 
Removing libandroid-properties1 (0.1.0+git20151016+6d424c9-0ubuntu7) ...  
Removing libappstream3:amd64 (0.9.4-1ubuntu2) ... 
Removing qtdeclarative5-unity-action-plugin:amd64 (1.1.0+14.04.20140304-0ubuntu2~gcc5.1) ... 
Removing libunity-action-qt1:amd64 (1.1.0+14.04.20140304-0ubuntu2~gcc5.1) ...  
Removing libhud2:amd64 (14.10+16.04.20160415-0ubuntu1) ... 
Removing qml-module-qtfeedback:amd64 (5.0~git20130529-0ubuntu13) ... 
Removing libqt5feedback5:amd64 (5.0~git20130529-0ubuntu13) ... 
Removing libqt5multimedia5:amd64 (5.6.1-2ubuntu1~xenialoverlay1~1) ... 
Removing libqt5positioning5:amd64 (5.6.1-2ubuntu1~xenialoverlay1~1) ...  
Removing qtdeclarative5-test-plugin:amd64 (5.6.1-4ubuntu1~xenialoverlay1~4) ... 
Removing qml-module-qttest:amd64 (5.6.1-4ubuntu1~xenialoverlay1~4) ... 
Removing qtdeclarative5-dev-tools (5.6.1-4ubuntu1~xenialoverlay1~4) ...  
Removing libqt5quicktest5:amd64 (5.6.1-4ubuntu1~xenialoverlay1~4) ...  
Removing libqt5test5:amd64 (5.6.1+dfsg-3ubuntu1~xenialoverlay1~4+fix1) ... 
Removing vbetool (1.1-3) ... 
Removing libx86-1:amd64 (1.1+ds1-10) ... 
Removing plainbox-provider-checkbox (0.25-1) ... 
Removing plainbox-provider-resource-generic (0.23-1) ... 
Removing python3-plainbox (0.25-1) ... 
Removing plainbox-secure-policy (0.25-1) ... 
Removing pm-utils (1.4.1-16) ... 
Removing pyotherside (1.4.0-2) ... 
Removing python3-checkbox-support (0.22-1) ... 
Removing system-config-printer-udev (1.5.7+20160212-0ubuntu2) ... 
Removing system-config-printer-common (1.5.7+20160212-0ubuntu2) ... 
Removing python3-cups (1.9.73-0ubuntu2) ... 
Removing python3-cupshelpers (1.5.7+20160212-0ubuntu2) ... 
Removing python3-guacamole (0.9.2-1) ...  
Removing python3-jinja2 (2.8-1) ... 
Removing python3-padme (1.1.1-2) ... 
Removing python3-pyparsing (2.0.3+dfsg1-1ubuntu0.1) ... 
Removing python3-requests (2.9.1-3) ... 
Removing python3-urllib3 (1.13.1-2ubuntu0.16.04.1) ... 
Removing python3-xlsxwriter (0.7.3-1) ... 
Removing qml-module-io-thp-pyotherside:amd64 (1.4.0-2) ...  
Removing qml-module-qt-labs-folderlistmodel:amd64 (5.6.1-4ubuntu1~xenialoverlay1~4) ... 
Removing qml-module-qt-labs-settings:amd64 (5.6.1-4ubuntu1~xenialoverlay1~4) ...
Removing qml-module-qtgraphicaleffects:amd64 (5.6.1-3ubuntu1~xenialoverlay1~2) ... 
Removing qml-module-qtquick-layouts:amd64 (5.6.1-2build1~~xenialoverlay1~1) ...  
Removing qml-module-qtquick-window2:amd64 (5.6.1-4ubuntu1~xenialoverlay1~4) ... 
Removing qtdeclarative5-accounts-plugin:amd64 (0.6+16.04.20151106-0ubuntu1) ...  
Removing qml-module-ubuntu-onlineaccounts:amd64 (0.6+16.04.20151106-0ubuntu1) ... 
Removing qtdeclarative5-qtquick2-plugin:amd645.6.1-4ubuntu1~xenialoverlay1~4) ... 
Removing qml-module-qtquick2:amd64 (5.6.1-4ubuntu1~xenialoverlay1~4) .. 
Removing qml-module-qtwebkit:amd64 (5.6.1+dfsg-4ubuntu1~xenialoverlay1~2) ...  
Removing qml-module-ubuntu-performancemetrics:amd64 (1.3.1918+16.04.20160404-0ubuntu1) ... 
Removing qmlscene (5.6.1-4ubuntu1~xenialoverlay1~4) ... 
Removing suru-icon-theme (14.04+16.04.20161024-0ubuntu1) ... 
Removing ubuntu-core-launcher (2.22.6) ... 
Removing ubuntu-mobile-icons (14.04+16.04.20161024-0ubuntu1) ... 
Removing ubuntu-ui-toolkit-theme (1.3.1918+16.04.20160404-0ubuntu1) ... 
Processing triggers for man-db (2.7.5-1) ... 
Processing triggers for libc-bin (2.23-0ubuntu5) ...  
Processing triggers for doc-base (0.10.7) ... 
Processing 1 removed doc-base file... 

samerlol@SamerLOL:~$ sudo apt-get install unity-tweak-tool gnome-tweak-tool 
Reading package lists... Done  
Building dependency tree        
Reading state information... Done 
Some packages could not be installed. 
This may mean that you have requested  an impossible situation 
or if you are using the unstable distribution
that some required packages have not yet been created 
or been moved out of Incoming. 
The following information may help to resolve the situation:  

The following packages have unmet dependencies:  
 unity-tweak-tool :  Depends: unity-webapps-common but it is not going to be installed 
E: Unable to correct problems, you have held broken packages.

samerlol@SamerLOL:~$ sudo apt-get purge unity-tweak-tool 
Reading package lists... Done 
Building dependency tree        
Reading state information... Done 
Package 'unity-tweak-tool' is not installed, so not removed 
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. 

samerlol@SamerLOL:~$ sudo apt-get purge --auto-remove unity-tweak-tool 
Reading package lists... Done 
Building dependency tree        
Reading state information... Done 
Package 'unity-tweak-tool' is not installed, so not removed 
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. 

samerlol@SamerLOL:~$ sudo apt-get clean 
samerlol@SamerLOL:~$ sudo apt-get install unity-tweak-tool 
Reading package lists... Done 
Building dependency tree        
Reading state information... Done 
Some packages could not be installed. 
This may mean that you have requested an impossible situation 
or if you are using the unstable distribution that some 
required packages have not yet been created or been moved out of Incoming. 
The following information may help to resolve the situation:  

The following packages have unmet dependencies:  
unity-tweak-tool :  
 Depends: unity-webapps-common but it is not going to be installed 
W: Target Packages (main/binary-amd64/Packages) is configured multiple times 
in /etc/apt/sources.list.d/google-chrome.list:3 and /etc/apt/sources.list.d/google.list:1 
W: Target Packages  (main/binary-all/Packages) is configured multiple times in  
/etc/apt/sources.list.d/google-chrome.list:3 and /etc/apt/sources.list.d/google.list:1 
W: Target Translations (main/i18n/Translation-en_US) is configured multiple times in  
/etc/apt/sources.list.d/google-chrome.list:3 and /etc/apt/sources.list.d/google.list:1 
W: Target Translations (main/i18n/Translation-en) is configured multiple times in  
/etc/apt/sourscreenshotces.list.d/google-chrome.list:3 and /etc/apt/sources.list.d/google.list:1 
W: Target DEP-11 (main/dep11/Components-amd64.yml) is configured multiple times in  
/etc/apt/sources.list.d/google-chrome.list:3 and /etc/apt/sources.list.d/google.list:1 
W: Target DEPscreenshot-11-icons (main/dep11/icons-64x64.tar) is configured multiple times in  
/etc/apt/sources.list.d/google-chrome.list:3 and /etc/apt/sources.list.d/google.list:1 
E: Unable to correct problems, you have held broken packages. 

samerlol@SamerLOL:~$ sudo apt-get clean  
samerlol@SamerLOL:~$ sudo apt-get autoclean 
Reading package lists...  
Done Building dependency tree        
Reading state information... Done  
W: Target Packages (main/binary-amd64/Packages) is configured multiple times in 
/etc/apt/sources.list.d/google-chrome.list:3 and /etc/apt/sources.list.d/google.list:1 
W: Target Packages (main/binary-all/Packages) is configured multiple times in  
/etc/apt/sources.list.d/google-chrome.list:3 and /etc/apt/sources.list.d/google.list:1 
W: Target Translations (main/i18n/Translation-en_US) is configured multiple times in  
/etc/apt/sources.list.d/google-chrome.list:3 and /etc/apt/sources.list.d/google.list:1 
W: Target Translations (main/i18n/Translation-en) is configured multiple times in  
/etc/apt/sources.list.d/google-chrome.list:3 and /etc/apt/sources.list.d/google.list:1 
W: Target DEP-11 (main/dep11/Components-amd64.yml) is configured multiple times in  
/etc/apt/sources.list.d/google-chrome.list:3 and /etc/apt/sources.list.d/google.list:1 
W: Target DEP-11-icons (main/dep11/icons-64x64.tar) is configured multiple times in  
/etc/apt/sources.list.d/google-chrome.list:3 and /etc/apt/sources.list.d/google.list:1 

samerlol@SamerLOL:~$ sudo apt-get -f install 
Reading package lists... Done 
Building dependency tree        
Reading state information... Done 
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. 

samerlol@SamerLOL:~$ sudo dpkg --configure -a 
samerlol@SamerLOL:~$ sudo apt-get -f install  
Reading package lists... Done 
Building dependency tree        
Reading  state information... Done 
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. 

samerlol@SamerLOL:~$ sudo apt-get -u dist-upgrade  
Reading package lists... Done 
Building dependency tree        
Reading  state information... Done 
Calculating upgrade... Done 
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. 

samerlol@SamerLOL:~$  
sudo apt-get install unity-tweak-tool 
Reading package lists... Done  
Building dependency tree        
Reading state information... Done 
Some packages could not be installed. 
This may mean that you have requested  
an impossible situation or if you are using the unstable distribution  
that some required packages have not yet been created or been moved out of Incoming. 
The following information may help to resolve the situation:  

The following packages have unmet dependencies:  
unity-tweak-tool :  
 Depends: unity-webapps-common but it is not going to be installed 
E: Unable to correct problems, you have held broken packages.

What should I do?

marked as duplicate by karel, Eric Carvalho, David Foerster, Zanna, Charles Green Feb 28 '18 at 1:08

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 2
    Please take pity on me and run those commands again, and edit your question to paste the output again and this time use the {} button instead of the " button to format as code – Zanna Mar 5 '17 at 21:58
  • First command "sudo apt-get remove --auto-remove unity-tweak-tool " the output : {Reading package lists... Done Building dependency tree Reading state information... Done Package 'unity-tweak-tool' is not installed, so not removed 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. } – Samer Yousef Mar 6 '17 at 12:52
  • Second Command: sudo apt-get install unity-tweak-tool gnome-tweak-tool The output: { The following information may help to resolve the situation: The following packages have unmet dependencies: unity-tweak-tool : Depends: unity-webapps-common but it is not going to be installed E: Unable to correct problems, you have held broken packages. } – Samer Yousef Mar 6 '17 at 12:56
  • To close voters: Please don’t close a question as a duplicate of another based on only warnings when there are actual errors that block what OP intends to do. – David Foerster Feb 27 '18 at 6:22
  • Could you please edit your question to include the output of sudo apt-get install -f unity-tweak-tool unity-webapps-common? Thanks. – David Foerster Feb 27 '18 at 6:26
0

When you deleted lots of packages, you probably deleted the one that unity-tweak-tool depends on.

Try installing the packages manually.

  1. Open up https://packages.ubuntu.com/ in your web browser.
  2. Scroll down to the Search package directories area.
  3. Select your version of Ubuntu from the Distribution drop down (In this case it's xenial).
  4. Type in the package name and click search (In this case it's unity-webapps-common)
  5. Click on the Exact Hit (In this case it's Package unity-webapps-common)
  6. Select either your computers architecture (amd64 for 64 bit and i386 for 32 bit) or all in the table at the bottom
  7. Select one of the links on the page. It's probably a good idea to select the one for your country but it doesn't matter.
  8. Open up a terminal and navigate to the directory that you downloaded the package to.
  9. Run sudo dpkg -i file.deb, where file.deb is the file that you just downloaded. Once this is done, try to install unity-tweak-tool again.

If it gives you the depends on error for a different package, just follow steps 1-9 for that package and try to install unity-tweak-tool again. You may have to do this multiple times.

Not the answer you're looking for? Browse other questions tagged or ask your own question.