2

My machine has been set up to dual boot Windows 10 and Ubuntu successfully for about a year now. Last night I tried to boot Ubuntu and I get this "Welcome to Emergency Mode" message:

Load Error - Emergency Mode

Hitting Ctrl+d causes the load screen to come up for a second before returning the message again. In repeatedly trying to get it to load I've also seen an error about "ldm_parse_tocblock" and "cannot find TOCBLOCK, database maybe corrupt." I haven't made any changes to my BIOS or setup and Windows 10 is running fine off of the same drive.

I'm lost on what might be wrong and how to provide more meaningful information here so that the hive is able to help me work through this. Any insight appreciated. Thanks!

9
  • 1
    Perhaps you need to change your UEFI settings after all and disable secure boot.
    – user589808
    Mar 6 '17 at 0:05
  • Do you dual-boot with Windows? If so, do you have a driver installed in Windows to read/write Ubuntu EXT4 partitions... like the Paragon driver? Do you know how to fsck sda5? Start new comments directed to me with @heynnema or I may miss them.
    – heynnema
    Mar 6 '17 at 17:46
  • @heynnema I plan on restarting and trying to change the secure boot settings in UEFI but I've never touched them before so I wonder why that would all of a sudden be an issue. As for the driver in windows to read/write to Ubuntu EXT4 partitions...I have no memory of installing anything like that. I remember changing settings in Ubuntu to read Windows partitions but not the other way around.
    – CraigPDX
    Mar 6 '17 at 18:15
  • Secure boot only needs to be disabled if you're running 3rd party unsigned kernel drivers in Ubuntu. Also, don't change the UEFI setting in your BIOS, or Windows 10 won't boot any more. Use the journalctl command as shown, and run the fsck command.
    – heynnema
    Mar 6 '17 at 18:49
  • > Use the journalctl command as shown, and run the fsck command. @heynnema I'm not certain how to use the journalctl command with fsck. Are you suggesting I enter in the screen about to enter maintenance and once in I should run fsck sda5?
    – CraigPDX
    Mar 6 '17 at 18:58
2

At the "recovering journal" error, hit the Enter key to enter maintenance mode, then at the # prompt, type:

journalctl -xb

review the text, and try to identify when/where an error occurred. Take a picture of anything that looks suspect to you, and edit it into your question, if you need more help. Then type:

fsck -f /dev/sda5

to check your file system.

If for some reason you can't do the fsck at the # prompt, you'll have to do it this way...

  • boot to the GRUB menu
  • choose Advanced Options
  • choose Recovery mode
  • choose Root access
  • at the # prompt, type sudo fsck -f /dev/sda5
  • repeat the fsck command if there were errors
  • type reboot

Update #1

  • boot to the GRUB menu
  • choose Advanced Options
  • choose Recovery mode
  • choose Root access
  • at the # prompt, type:
    • sudo mount -o rw,remount /
    • sudo pico /etc/fstab
    • use arrow keys to move cursor
    • use control-o and then Enter to save file
    • use control-x to exit pico
    • comment out the lines that contain "Storage" and "Locker" by placing a # in front of the UUID at the beginning of those two lines (ie: #UUID=)
    • save file and quit pico
    • reboot
6
  • this same scenario is happening to me again. I was able to run fsck but this check didn't work magic this time around. Here are two screen caps: Screen Cap 1 and Screen Cap 2 Any thoughts
    – CraigPDX
    Apr 9 '17 at 5:24
  • the fsck didn't work 'cause the drive is mounted. Do sudo mount -o ro,remount /dev/sda5 and then fsck, or just use the second part of my answer to resolve the problem.
    – heynnema
    Apr 9 '17 at 13:53
  • So it appears that I was able to mount and remount the drive successfully. I ran fsck but I was still unable to boot up Ubuntu. Screen Cap I did run with sudo as well but it seems that I had root permission and didn't need it. What is changing that would cause this. Windows and Ubuntu are in separate partitions so I'd assumed they wouldn't directly effect each other.
    – CraigPDX
    Apr 10 '17 at 4:16
  • Dual-boot configurations can cause problems for each other. If we get you booted, I can give you the fixes for that. For now, without being able to review the journal with journalctl -xb, I'm having to kind of take some good guesses. See if you can look at it, and show me anything that looks suspect to you. Also, show me the output of sudo blkid and cat /etc/fstab. If you run boot-repair, you can also show me the log that it creates.
    – heynnema
    Apr 10 '17 at 14:38
  • Here's a screen cap that includes the output of blkid and fstab commands. I need to wade through the output of journalctl -xb.
    – CraigPDX
    Apr 12 '17 at 18:58
0

Make a bootable USB key with the same or newer version of Ubuntu on it. You can do this under Windows.

Boot from it and check your Ubuntu partitions for errors.

Try booting off the Ubuntu installation again, and if it works, do a full system update immediately then reboot. The quickest way is to type the following commands:

sudo -s
apt update
apt full-upgrade -y
apt autoremove -y
apt clean
apt purge

Then reboot.

The last 3 commands clean up after the update. This is an often-neglected step.

If checking the disk using a key doesn't help, I suggest reinstalling over the top. This should keep your files and settings so long as you do not reformat the disk.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.