0

I know there are a ton of nvidia driver-related questions, but I tried everything I could find and none worked.

I am using an ASUS ROG GL752VW, core i7 6700HQ, nvidia GTX 960M 4GB GDDR5. I first installed Windows 10 and left ~200GB for my linux OS.

  1. Created Ubuntu 14.04 Live-USB with rufus
  2. Tried to boot from the live USB. Did not work, had to enable nomodeset from the advanced boot options, because it stuck at Starting CUPS printing spooler/server [ OK ] (solution from here.
  3. After successfully installed, tried installing the drivers apt-get install nvidia-current
    • After reboot, stuck in a login loop (after inserting correct password, screen would go back to login)
    • Uninstalled the drivers apt-get remove --purge nvidia-*
  4. Tried add-apt-repository ppa:graphics-drivers/ppa and installing the newer drivers (latest is 378)
    • Again, same thing happened
    • Uninstalled them once again
  5. Tried this, this, this and this. Nothing worked, same issue.
  6. Tried several different drivers (304, 170, 358, 367, 285 and more), with no result.

I also had a GTX 950M laptop and it was working perfectly with nvidia-367 driver.

Could it be a problem with the actual card? If so, has anyone managed to get it working on an UNIX system?

Thanks in advance.

  • Disable Secure Boot in BIOS. – Pilot6 Mar 5 '17 at 17:37
  • Secure Boot was already disabled, I checked that before installing. – Alex Mar 5 '17 at 17:37
  • What is your linux architecture? x64 or x86? What linux specificaly are you trying to use? As far as I can see on nvidia site, your GPU is supported only on x86 architecture. Take a look at NVIDIA drivers operating systems list currently supporting your GPU here: nvidia.com/Download/index.aspx?lang=en. As far as I remember I had issues installing Ubuntu on my PC next to Windows. I can't recall what I did to resolve it but I think I checked what specific version of Ubuntu is supporting NVIDIA drivers and it turned out that Ubuntu 15.04 worked for me. – jedi Mar 5 '17 at 17:57
  • You installed the wrong drivers. nvidia-current install an old extended support driver which is NOT compatible with brand new(ish) hardware like the GTX960M. Also, why 14.04? For your hardware 16.04 or 16.10 has much better support. @jedi - Please delete your comment. It's wrong, misleading and you shouldn't be using outdated releases let alone recommend it. – user589808 Mar 5 '17 at 18:53
  • @jedi I am using Ubuntu 14.04 x64. As I just checked the nvidia website, the driver 375.39 for Linux x64 supports GTX 960M. – Alex Mar 5 '17 at 19:01

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.