0

I have Ubuntu 14.04 box, which was powered off for several months. I have turned it on, it worked, also network worked and I foolish ran sudo apt-get upgrade.

This caused my system has no network anymore. During boot, it displays messages from this "waiting for network configuration" Problem question. The solution from this question (strange one) does not work for me. I mean, if I remove eth0 from /etc/netwrok/interfaces then error message disappears but network doesn't appear.

Machine has two network devices, which are marked UNCLAIMED by sudo lshw -C network.

How to fix?

UDPATE

I have read that this may be related with glitching network-manager and uninstalled it (it was installed) - this didn't help.

ifconfig shows only loopback interface.

UDPATE 2

sudo ifup eth0 says

Cannot find device "eth0"
Error getting hardware address for "eth0": No such device
Failed to bring eth0 up eth0

UPDATE 3

Configuring eth0 as static didn't help.

  • Are you asking about a wire or wireless network? – Pilot6 Mar 5 '17 at 11:21
  • And all is unclear. Is it a server, why network is configured without NM? What does ifconfig show? – Pilot6 Mar 5 '17 at 11:24
  • @Pilot6 network is wired, both cards are wired. I don't know if it is server, but it loads w/o GUI. I would prefer it was headless machine. – Dims Mar 5 '17 at 11:40
  • Will you update your question and show the output of ifconfig? By the way, NetworkManager would not have been the reason for your network to stop working. It will ignore the interfaces that you have manually configured. – L. D. James Mar 5 '17 at 13:49
  • UNCLAIMED typically means that there is no driver associated with the device. Please edit your question to include: lspci -nnk | grep 0200 -A2 – chili555 Mar 5 '17 at 14:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.