0

This is not a duplicate of Why does DVD playback still not work after installing libdvdcss2? as the answers there are not valid for 16.04

I've reveiwed https://help.ubuntu.com/community/RestrictedFormats/PlayingDVDs and installed the libdvd-pkg with sudo apt-get install libdvd-pkg

I've checked that the region is set:

sudo regionset /dev/sr0
regionset version 0.1 -- reads/sets region code on DVD drives
Current Region Code settings:
RPC Phase: II
type: SET
vendor resets available: 4
user controlled changes resets available: 4
drive plays discs from region(s): 1, mask=0xFE    

Would you like to change the region setting of your drive? [y/n]:n

I didn't change as it's set for:

Region 1: U.S., U.S. Territories, Canada, and Bermuda. which should be correct.

I double checked that the package is installed with

$ dpkg -l |grep dvd
ii  dvd+rw-tools                                         7.1-11                                        amd64        DVD+-RW/R tools
ii  dvdauthor                                            0.7.0-1.4                                     amd64        create DVD-Video file system
ii  libdvd-pkg                                           1.4.0-1-1                                     all          DVD-Video playing library - installer
ii  libdvdnav4:amd64                                     5.0.3-1                                       amd64        DVD navigation library
ii  libdvdread4:amd64                                    5.0.3-1                                       amd64        library for reading DVDs

I even went so far as to issue the command.

sudo dpkg-reconfigure libdvd-pkg

This package automates the process of launching downloads of the source files for libdvdcss2 from videolan.org, compiling   │ 
  │ them, and installing the binary packages (libdvdcss2 libdvdcss-dev).                                                        │ 
  │                                                                                                                             │ 
  │ Please confirm whether you wish this to happen.                                                                             │ 
  │                                                                                                                             │ 
  │ Download, build, and install libdvdcss2/1.4.0-1?                                                                            │ 
  │                                                                                                                             │ 
  │                                     <Yes>  

A picture would have been better above but you get the idea. Output was:

libdvd-pkg: Downloading orig source...
I: libdvdcss_1.4.0
/usr/bin/wget --tries=3 --timeout=40 --read-timeout=40 --continue -O libdvdcss_1.4.0.orig.tar.bz2 \
          http://download.videolan.org/pub/libdvdcss/1.4.0/libdvdcss-1.4.0.tar.bz2 \
        || /usr/bin/uscan --noconf --verbose --rename --destdir=/usr/src/libdvd-pkg --check-dirname-level=0 --force-download --download-current-version /usr/share/libdvd-pkg/debian
--2017-03-04 17:55:39--  http://download.videolan.org/pub/libdvdcss/1.4.0/libdvdcss-1.4.0.tar.bz2
Resolving download.videolan.org (download.videolan.org)... 88.191.250.2, 2a01:e0d:1:3:58bf:fa02:c0de:5
Connecting to download.videolan.org (download.videolan.org)|88.191.250.2|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 364373 (356K) [application/octet-stream]
Saving to: ‘libdvdcss_1.4.0.orig.tar.bz2’

libdvdcss_1.4.0.orig.tar.bz2     100%[==========================================================>] 355.83K   795KB/s    in 0.4s    

2017-03-04 17:55:40 (795 KB/s) - ‘libdvdcss_1.4.0.orig.tar.bz2’ saved [364373/364373]

libdvd-pkg: Checking orig.tar integrity...
/usr/src/libdvd-pkg/libdvdcss_1.4.0.orig.tar.bz2: OK
libdvd-pkg: Unpacking and configuring...
libdvd-pkg: Building the package... (it may take a while)
libdvd-pkg: Build log will be saved to /usr/src/libdvd-pkg/libdvdcss2_1.4.0-1~local_amd64.build
Current: = cap_chown,cap_dac_override,cap_dac_read_search,cap_fowner,cap_fsetid,cap_kill,cap_setgid,cap_setuid,cap_setpcap,cap_linux_immutable,cap_net_bind_service,cap_net_broadcast,cap_net_admin,cap_net_raw,cap_ipc_lock,cap_ipc_owner,cap_sys_module,cap_sys_rawio,cap_sys_chroot,cap_sys_ptrace,cap_sys_pacct,cap_sys_admin,cap_sys_boot,cap_sys_nice,cap_sys_resource,cap_sys_time,cap_sys_tty_config,cap_mknod,cap_lease,cap_audit_write,cap_audit_control,cap_setfcap,cap_mac_override,cap_mac_admin,cap_syslog,cap_wake_alarm,cap_block_suspend,37+ep
Bounding set =cap_chown,cap_dac_override,cap_fowner,cap_wake_alarm,cap_block_suspend,37
Securebits: 024/0x14/5'b10100
 secure-noroot: no (unlocked)
 secure-no-suid-fixup: yes (unlocked)
 secure-keep-caps: yes (unlocked)
uid=0(root)
gid=0(root)
groups=0(root)
libdvd-pkg: Installing...
Selecting previously unselected package libdvdcss-dev:amd64.
(Reading database ... 387303 files and directories currently installed.)
Preparing to unpack .../libdvdcss-dev_1.4.0-1~local_amd64.deb ...
Unpacking libdvdcss-dev:amd64 (1.4.0-1~local) ...
Selecting previously unselected package libdvdcss2:amd64.
Preparing to unpack .../libdvdcss2_1.4.0-1~local_amd64.deb ...
Unpacking libdvdcss2:amd64 (1.4.0-1~local) ...
Setting up libdvdcss2:amd64 (1.4.0-1~local) ...
Setting up libdvdcss-dev:amd64 (1.4.0-1~local) ...
Processing triggers for libc-bin (2.23-0ubuntu5) ...
me@64bitUbuntu:~$ 

Further details: System SettingsDetailsRemoveable Mediais set to Ask What to Do

The drive recognizes the insertion of the disk And the title shows up in Nautilus and totem but attempting to play in totem results in "Can't Read DVD" The same drive reads CD's flawlessly and the same DVD plays perfectly in another system. this machine was an upgrade from 14.04 but on 2 other systems that were installed fresh with 16.04 I have one that exhibits this problem and another that doesn't.

EDIT: I tried deleting ~/.dvdcss folder. No help although there were some keys stored there. and while the documentation here was informative no amount of playing with the environment variables for decryption resulted in success.

  • Try deleting ~/.dvdcss folder, then from terminal see what happens with export DVDCSS_METHOD=title && totem dvd:// You could also use libdvdcss in debug mode though for that a little easier with vlc. shown ubuntuforums.org/… – doug Mar 5 '17 at 1:22
  • @doug Thanks for the pointers. It turned out to be rather simple after I got some sleep – Elder Geek Mar 5 '17 at 14:52
2

Much to my embarrassment, In this case the root cause was a temporary hardware problem known as dust on the lens. Easily resolved with a can of compressed air. Opening the tray and blowing the dust off the lens on the systems displaying this issue worked wonders.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.