5

I installed WPS Office for the first time. It is amazing, so much so that I wonder if there is some hidden adware that I can't remove (e.g., what is Docer).

That said, my issue is that the background on WPS Spreadsheets for all sheets is this weird brown color. I've tried changing the Page Layout > Themes and Colors. I've also tried to Format Cells. But there does not appear (or I can't find) a way to change the default background color. Is there a way?

Here is what it looks like.

enter image description here

4

As an addendum to Roel Brook's answer, I found that you can actually change this setting in the binary file. To do this open terminal and enter

sudo $EDITOR `where et`

Then look for:

${gInstallPath}/office6/${gApp} -style gtk+ ${gOptExt} ${gOpt} "$@"

and change it to:

${gInstallPath}/office6/${gApp} -style motif ${gOptExt} ${gOpt} "$@"

Then save and close. Now the changes will be persistent.

  • 2
    Thanks @Dan Temkin. I attempted to edit the binary file, but I had no et file in /bin. Instead, it was at /usr/bin/et. Also, and more importantly, it doesn't have the line you mention. There is no -style gtk+ anywhere in the file. The closest line I have is: else ${gInstallPath}/office6/${gApp} ${gOptExt} ${gOpt} "$@" . Am I in the wrong directory? – Rsync Jul 7 '17 at 2:51
  • I missed the 5 minute edit time restriction. Here is what I meant to add: Despite the different directory, I added -style motif in the same place you had it. And it worked!!! I'm going to go through a few restarts to see if it sticks. If so, I'll mark it solved and thank you very much. – Rsync Jul 7 '17 at 2:57
2

As with most QT applications, WPS accepts "-style".

For example: et -style motif

This will ignore the current desktop theme, and run WPS with that specific QT theme.

  • Thanks @Roel Brook, but that solution actually doesn't work other than when launching through the terminal. If you put the et -style motif in the .desktop file in /usr/share/applications, it only works when you launch from that directory. Else (e.g., if you open a .xlsx file in another location or a blank document), it keeps the brown background. – Rsync Jul 7 '17 at 2:49
  • works for me if I edit the launcher properties in Linux Mint Cinnamon 18 as follows: command: /usr/bin/et -style motif – flyingdrifter Nov 28 '17 at 16:50
2

GTK theme have to be set with environment variable and parameter

env GTK2_RC_FILES=/usr/share/themes/Adwaita/gtk-2.0/gtkrc ./et -style gtk+

Can you show a way to input this parameter to the application to be persistent? >>I'm using KDE Neon 5.14 User Edition (Based Ubuntu 18.04)

Thanks a Lot man

--UPDATE--

Knowing about this tip that intika said, a precious one by the way, I searched a little more to How to make this line as permanent. So, its very simple.

Right Click > Edit Application > Application tab > Run or Command box-form and add "Exec="on begining.

For exemple:

Exec=env GTK2_RC_FILES=/usr/share/themes/Adwaita/gtk-2.0/gtkrc /usr/bin/et -style gtk+

This solved my problem. Take care to do not put this command to run in a terminal on advanced settings, or It will open terminal together (unless you want it)

  • This is a great, useful answer and it's valuable that you point out the potential problems one could have. One minor improvement could be to make it less of a log of what you did and more a description of what should be done, as that'd be more readable for future readers. (For example, you could change the second update to something like "Be careful not to enable the option to run in a terminal (...), as that causes a terminal to be opened at the same time as the spreadsheet(...)".) – aplaice Jan 18 at 22:35
  • @aplaice . Thank you, I read about to write a good answer, but in the end, i dont get it very well. I will edit this post to make more readable to future reader. Thanks a lot for the tip. – Rodrigo Miguel Jan 21 at 15:11
  • If you installed WPS through snap... edit /var/lib/snapd/desktop/applications/wps-office_et.desktop and add it like: Exec=env GTK2_RC_FILES=/usr/share/themes/Adwaita/gtk-2.0/gtkrc BAMF_DESKTOP_FILE_HINT=/var/lib/snapd/desktop/applications/wps-office_et.desktop /snap/bin/wps-office.et -style gtk+ %U – lepe May 24 at 9:13
1

Turns out this is caused by an interaction with the Arc Dark theme (it does not occur with Arc or Arc Darker). I posted an issue on Horst's GitHub page.

1

GTK theme have to be set with environment variable and parameter

env GTK2_RC_FILES=/usr/share/themes/Adwaita/gtk-2.0/gtkrc ./et -style gtk+
  • I get gtk+ not a valid file – Raza May 7 at 18:04
0

I had the same problem, but the solution above given by Dan (which seems to be the right one as it is referenced in every forum I came across) wasn't working for me. But I found another fix which DOES work, although not permanently.

I am using a KDE neon build, and the solution below worked for me:

WPS_NO_KDE_NATIVE_DIALOG=1 et -style gtk+

This is for spreadsheets. For writer and presentation, substitute "et" with "wps" and "wpp" respectively.

Solution attributed to user "raddison" on KDE Forum, under the "WPS Office not working" topic.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.