1

Ubuntu 12.02 32 bit printer program executable file cannot run properly in Ubuntu 14.04 64 bit I installed bellow three library packages but it's not working.

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install libc6:i386 libncurses5:i386 libstdc++6:i386
./example32bitprogram**
0

There are at least two plausible major reasons for it not working:

  1. Software created for an older version of an OS, and you're trying to run it under a newer version, where the new OS has had numerous changes applied.
  2. On top of that the software intended for the 32bit version of the OS, and are trying to run it under the 64bit version of the OS.

I'd say this is a situation where the software MIGHT run (given the right conditions), but that cannot be guaranteed.

Adding the first level of dependencies might not be enough, there might be a number of subsequent (levels of) dependencies.

0

I solved the problem.

dpkg --print-architecture
dpkg --print-foreign-architectures
sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get dist-upgrade

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.