0

According to this post

Cannot change Intel turbo boost (/sys/devices/system/cpu/intel_pstate/no_turbo/ not accessible)

I followed the steps. And it seems like I have to disable Turboboost at BIOS because I faced the same problem as him, but my BIOS doesn't have an option to disable it (InsydeH2O BIOS). I have to disable it because I want to test the FLOPs via PAPI.

So I would like to ask if there are alternative ways to disable it?

  • 1
    Yes, but the person on the link you gave was interpreting the meaning of turbo enabled or disabled backwards. In his case, it was already disabled in the BIOS. Could you please add some of the similar information to your question. And what is your processor model? – Doug Smythies Mar 3 '17 at 17:36
  • I'm sorry. I did echo "1" | sudo tee sys/devices/system/cpu/intel_pstate/no_turbo and it worked properly. Maybe it's because of gedit because I got the same error as him on gedit. But when I checked via grep MHz /proc/cpuinfo, it seems that CPU freq scaling is still enabled. How can I stop this feature temporarily to run PAPI's FLOPs testing program. My CPU is Intel® Core™ i7-4700MQ CPU @ 2.40GHz w/ 4 cores and 8 threads. – EkBumYe Mar 4 '17 at 15:22
  • Set all CPUs to use the performance frequency scaling governor. However note that the CPU itself can still backoff its own frequency under very low load conditions, but the response time to a stable CPU frequency will be the fastest in performance mode. Do: sudo su then for file in /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor; do echo "performance" > $file; done then check it cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor then exit. – Doug Smythies Mar 4 '17 at 15:35
  • It didn't work, even if I restarted. CPU clocks are still variant, but nearly closed to each other (about 2400). PAPI still cannot detect stable clock. – EkBumYe Mar 4 '17 at 16:03
  • Well, that would be PAPI's problem. Modern CPUs vary the clock frequency. If your BIOS has the option, then try disabling Intel Speedstep. – Doug Smythies Mar 4 '17 at 16:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.