0

After a power outage, I reboot the computer.

However when I login and press enter, the screen turns black for a moment and then the login screen comes again.

If I press ctrl alt f1 and type 'startx' the screen turns completely black for a moment and then I see the console again, with no apparent error but "server terminated successfully". This is the xorg log: http://pastebin.com/Q9aLxBZz .

I've already tried to rm the .Xauthority file or sudoing startx but it doesn't work. How could I solve the problem? I urgently need to use the computer :/

  • I see this [ 1462.940] (EE) Failed to load module "fglrx" (module does not exist, 0) in the paste bin, what version of Ubuntu are u using? – George Udosen Mar 3 '17 at 16:41
  • vivid.. everything worked well right before the outage :/ – Surfer on the fall Mar 3 '17 at 16:47
1

Error code:

[  1462.940] (EE) Failed to load module "fglrx" (module does not exist, 0)

Ubuntu's page for fglrx: http://packages.ubuntu.com/search?keywords=fglrx

Try this:

sudo apt-get install fglrx && telinit 6

This command will install the missing module and reboot your computer.

  • but it worked perfectly right before the outage.. how could it be a missing package? – Surfer on the fall Mar 3 '17 at 17:18
  • Maype while uninstalling a package apt removed it - or maybe a failed system upgrade. I DON'T know why, but X says in the logs that the load module "does not exist". – Thomas William Mar 3 '17 at 17:23
0

The root partition might be damaged because of the power outage.

  • I suggest that you boot your computer from another drive, for example an Ubuntu DVD or USB boot drive.

  • Then identify the root partition (and the home partition if there is such a partition too) with the following commands

    sudo lsblk -f
    sudo lsblk -m
    sudo parted -ls
    
  • When you know the drive letter (often but not always a) and partition number (often 1 or 5), unmount the partition(s) you want to repair (if they are mounted)

    sudo umount /dev/sdxn      # general command
    sudo umount /dev/sda1      # example (drive a, partition 1)
    
  • Run the following command

    sudo e2fsck -f /dev/sdxn   # general command
    sudo e2fsck -f /dev/sda1   # example (drive a, partition 1)
    

    Text after # is a comment (not used).

    It takes several minutes (even hours in some cases). Sometimes it is fully automatic, sometimes it wants you to confirm some repair actions.

    See the manual page if you want to know details about the e2fsck program.

    man e2fsck
    
  • Reboot the computer (and remove the DVD/USB drive). If you are lucky it works again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.