Unable to mount HDD

Error mounting /dev/sdb at /media/manuel/HDD: Command-line `mount -t "ext4" -o "uhelper=udisks2,nodev,nosuid" "/dev/sdb" "/media/manuel/HDD"' exited with non-zero exit status 32: mount: wrong fs type, bad option, bad superblock on /dev/sdb, missing codepage or helper program, or other error

   In some cases useful info is found in syslog - try
   dmesg | tail or so.

And "disks" shows that the disk is only 1.8TB instad of 4TB :

enter image description here

Context : I've added this drive in an old Desktop 4 years ago which failed on me last year. I don't recall having to do anything to be able to use all the 4TB but I have poor memory. Since then I've mounted it every once in a while as a backup plugging it into a gutted Lacie external case that a friend lent me. Having returned the case I did the same to my own Lacie case today, removed the HDD inside to plug my 4TB HDD instead. This is when the mount error happened. The last time it worked, with my friend's, it was 6 months ago, it was with the same laptop machine, without any windows, only 1 4TB partition.

Everything is the same but the case, which should have no incidence (it works fine with the original drive and another one), so what could it be? I know nothing of disks and partitions, so please help me not lose the data, it would be a disaster...

UPDATE : After the suggestion in the comment, I ran testdisk 7.0enter image description here As I showed in previous snapshot, the OS only knows of 1.8TB of the 4TB. Again, I don't recall ever having to tweak anything in the OS to be able to use the 4TB before but maybe upgrading from 15.10 to 16.04 is what broke it. Would restoring the recognized size of the HDD to 4TB solve everything?

UPDATE 2 : I have now tried my Lacie case with another HDD with over 2TB, having 3TB and it also shows A fragment of the total space : enter image description here. Since its partition is not over 2TB the error message is not displayed I imagine. So if it's the case that the case (no pun intended) can't access the 2 fist plates, amounting to 2TB, I'll try with another case.

  • 1
    Maybe your partition table has been corrupted somehow. To find out and eventually repair, you might install and run testdisk (see cgsecurity.org/wiki/TestDisk_Step_By_Step). Or is there something wrong with your "Lacie case"? – ridgy Mar 3 '17 at 14:47
  • As I said, I've tested the case with 2 other disks that mount fine, but I will try just in case. Your software also. Btw isn't there some fsck tool or something that would do the same? – sinekonata Mar 3 '17 at 21:28
  • 1
    See also thread above you now. askubuntu.com/questions/889289/how-to-setup-a-6tb-hd-on-ubuntu But if using an old external caddy can be the issue. Many have reported issues with older caddies and either larger drives or even smaller drives with gpt partitioning. – oldfred Mar 4 '17 at 15:11
  • Oh that is gold @oldfred, that gives me so much hope. Mine might be slightly older indeed or maybe my friend's was 2TB+... thanks will try both those things. – sinekonata Mar 4 '17 at 16:01

As @oldfred pointed out, there is an issue with the case. Thank you for pointing that out. Being the same brand and (apparent) model, I did not look into it so much but yes, I tested the faulty case with a 3TB I borrowed and the same happened, i.e. 2 less TB were available = 800GB instead of the 3.

I then tried my disk on an old computer at a friend's and was able to get the whole partition of 4TB.

So thank you again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.