I am "the friend" referred to in the questions here and here. I decided to come and ask a question myself, as I can still not connect to the wireless network.

I downloaded Keryx, as suggested here, and managed to download the necessary package and its dependencies. When I attempted to install the packages on Ubuntu using Keryx, Keryx just closed. Following this, I installed the packages manually using dpkg, and as far as I can tell, this was successful:

kieran@ubuntu:~$ cd /host/wifi/Keryx/keryx/projects/Kieran/packages
kieran@ubuntu:/host/wifi/Keryx/keryx/projects/Kieran/packages$ sudo dpkg -i *.deb
[sudo] password for kieran: 
Selecting previously deselected package bcmwl-kernel-source.
(Reading database ... 118296 files and directories currently installed.)
Unpacking bcmwl-kernel-source (from bcmwl-kernel-source_5.60.48.36+bdcom-0ubuntu5_i386.deb) ...
Selecting previously deselected package dkms.
Unpacking dkms (from dkms_2.1.1.2-3ubuntu1.1_all.deb) ...
Selecting previously deselected package fakeroot.
Unpacking fakeroot (from fakeroot_1.14.4-1ubuntu1_i386.deb) ...
Selecting previously deselected package linux-image.
Unpacking linux-image (from linux-image_2. ...
Selecting previously deselected package menu.
Unpacking menu (from menu_2.1.44ubuntu1_i386.deb) ...
Selecting previously deselected package patch.
Unpacking patch (from patch_2.6-2ubuntu1_i386.deb) ...
Setting up fakeroot (1.14.4-1ubuntu1) ...
update-alternatives: using /usr/bin/fakeroot-sysv to provide /usr/bin/fakeroot (fakeroot) in auto mode.
Setting up linux-image ( ...
Setting up menu (2.1.44ubuntu1) ...
Setting up patch (2.6-2ubuntu1) ...
Processing triggers for man-db ...
Setting up dkms ( ...
Setting up bcmwl-kernel-source ( ...
Loading new bcmwl- DKMS files...
First Installation: checking all kernels...
Building only for 2.6.35-22-generic
Building for architecture i686
Building initial module for 2.6.35-22-generic

wl.ko: Running module version sanity check. - Original module - No original module exists within this kernel - Installation - Installing to /lib/modules/2.6.35-22-generic/updates/dkms/


DKMS: install Completed. update-initramfs: deferring update (trigger activated) Processing triggers for install-info ... Processing triggers for doc-base ... Processing 31 changed 1 added doc-base file(s)... Registering documents with scrollkeeper... Processing triggers for menu ... Processing triggers for initramfs-tools ... update-initramfs: Generating /boot/initrd.img-2.6.35-22-generic Warning: No support for locale: en_GB.utf8

After rebooting, however, there were still no wireless networks in the NetworkManager Applet list. I opened the file /var/lib/NetworkManager/NetworkManager.state, and both NetworkEnabled and WirelessEnabled were set to True.

While i'm very concious I may be asking a stupid question here, both my friend and I have nothing left to suggest, and as such - I would be very grateful for any answers as to how to get wireless working.

  • Is the wifi LED illuminated? When you right-click the networking icon in the top right, is "enable wireless" present and checked?
    – dgmdan
    Oct 22, 2010 at 22:11
  • @dgmdan Enable wireless is not present. There is "enable networking", which is ticked.
    – Kkelk
    Oct 23, 2010 at 11:45
  • "Enable wireless is not present. There is "enable networking", which is ticked." This means that there is a problem seeing your wireless card. If the packages installed OK (it looks like they did, and by the way, they put those packages on the CD, which is really good to know), then make sure your wireless card is on.
    – zpletan
    Jan 16, 2011 at 13:40

3 Answers 3


Maybe a stupid answer but I had an issue where my nm did not see any wireless networks. I found it was simply my wireless hardware was not on, the laptop hotkey for enabling the wireless card was not operating properly. Once I sorted that the wireless in nm appeared.

If you boot using a live CD does Ubuntu hardware manager see you wireless card and offer a driver?

  • Wireless won't work on Live since it's a Broadcom chipset depending on proprietary drivers to function - it's mentioned so in the linked questions. While I myself own a laptop with Broadcom chipset with proprietary drivers, I did not face this issue.
    – Oxwivi
    Mar 9, 2011 at 15:12

Is there a hardware switch for the wireless card? It's surprisingly easy to turn off the radio and network manager doesn't know about it.

  • No, it works fine on Windows XP (i'm using a dual boot through wubi, as mentioned in the linked questions).
    – Kkelk
    Oct 22, 2010 at 20:41

If you have a Broadcom driver and no connections show up in the network manager

sudo apt-get update
sudo apt-get install bcmwl-kernel-source

Then go to System > Administration > Additional Drivers

Activate the drivers.

Then restart the wireless:

sudo modprobe -r b43 ssb wl
sudo modprobe wl

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.