0

So I'm trying to install packet tracer and it says that is successfully installed

enter image description here

and to type "packettracer" in terminal to start Cisco packet tracer. But nothing happens. I would be really grateful if someone tell me how to start it :D :)

5
  • Please edit the output of ls -l /usr/local/bin/pack*into your post or better yet sudo find / -name packettracer output – Elder Geek Mar 2 '17 at 18:16
  • I tried to find it with sudo find and it says that there is no such file :/ – sunnshiine96 Mar 2 '17 at 18:22
  • At teh risk of repeating myself, Please edit the outputs requested into your post so that we can see them for ourselves. Thank you for helping us help you! – Elder Geek Mar 2 '17 at 19:04
  • Another idea would be to reinstall it as it appears that your installation failed with an error when you chose Downloads as the target directory. – Elder Geek Mar 2 '17 at 19:06
  • Please review askubuntu.com/help/someone-answers Thank you! – Elder Geek Mar 2 '17 at 19:21
0

Since your installation failed mid-process due to your choice to install in the Downloads folder, Attempt installation again and choose a more appropriate location (the default should work fine).

2

This should work and you can find instructions on how to assign files and create a desktop launcher here

Download Packet Tracer 7 from NetAcad

Open a terminal (Ctrl + Alt + t) and extract the tar file :

$ cd ~/Downloads
$ tar xzvf PacketTracer70_64bit_linux.tar.gz

Start the installation :

$ sudo ~/Downloads/PacketTracer70/./install

You will be ask to accept the terms and select a location to install (press ‘Enter’ to select the default location /opt/pt )

You can launch PT7 by typing ‘packettracer’ in a terminal

Delete the installation files :

$ sudo rm -rf ~/Downloads/{PacketTracer70,PacketTracer70_64bit_linux.tar.gz}
0

I also faced the same issue and have resolved it, following is what I did in order to resolve the issue. Probably should work for you as well.

navigate to /opt/pt/bin and run the PacketTracer7 file

I got a unable to find or missing libpng12.so.0 when I tried to run the PacketTracer7

locate libpng12.so.0 # I found it in /snap/core/7169/lib/x86_64-linux gnu/libpng12.so.0

packettracer needs that in /usr/lib so issue the following command

sudo ln -s /snap/core/7169/lib/x86_64-linux-gnu/libpng12.so.0 /usr/lib/libpng12.so.0

and Thats all, now you just run packettracer it would run. So if you have some other library missing etc just follow the same procedure to solve the problem. Hope this answers your query.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.