0

My problem is that when I restart my computer, Ubuntu recognize my wireless keyboard and mouse usb dongle, but it doesn't recognize my usb wireless network adapter. Here is my lsusb results:

Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 002: ID 046d:c52e Logitech, Inc. MK260 Wireless Combo Receiver
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

The device that is not recognized is:

"Bus 001 Device 003: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter"

As soon as I manually unplug it and plug it back again, I can see it in my usb devices list and it works fine, but I can't do that every time I reboot my computer. I'm looking for a way to fix this or at least put something in my .bashrc to unplug this specific device and put it back so it works. Or maybe restarting that usb port to force it to check again. Any solutions is a huge help.

I know that there are a lot of questions similar to this one but I ask it because none of them worked for me.

0

I have a similar wifi usb dongle and had just the same problem. I was web searching for a working solution very long. But I found one. Later, after I interchanged the usb plugs, it doesn't work anymore. In order to reproduce my solution I was looking for hours again. On that way I found this question. My solution step by step is:

  1. ls /sys/bus/usb/drivers/
    lists for instance: hub r8712u uas usb usbfs usb-storage
    Pick the driver of desired usb device r8712u.

  2. ls /sys/bus/usb/drivers/r8712u
    lists for instance: 1-2.2:1.0 bind module new_id remove_id uevent unbind
    First entry 1-2.2:1.0 is id of usb device. This id should be valid as long as the usb device is connected to the same usb port.

  3. Disconnect and reconnect usb port at logon or startup. In my case I needed a delay of 3 seconds. Therefor call for instance:
    sudo nano /etc/rc.local
    Before exit 0 insert following 3 lines. Replace 1-2.2:1.0 and r8712u suitable.

    sleep 3
    echo '1-2.2:1.0' > /sys/bus/usb/drivers/r8712u/unbind
    echo '1-2.2:1.0' > /sys/bus/usb/drivers/r8712u/bind
    

    Afterwards /etc/rc.local should look like this

    #!/bin/sh -e
    #
    # rc.local
    #
    # This script is executed at the end of each multiuser runlevel.
    # Make sure that the script will "exit 0" on success or any other
    # value on error.
    #
    # In order to enable or disable this script just change the execution
    # bits.
    #
    # By default this script does nothing.
    
    sleep 3
    echo '1-2.2:1.0' > /sys/bus/usb/drivers/r8712u/unbind
    echo '1-2.2:1.0' > /sys/bus/usb/drivers/r8712u/bind
    exit 0
    
  4. If necessary enable the script with
    sudo chmod ugo+x /etc/rc.local

  • since my issue is mysteriously solved in Ubuntu 18 I can't verify your answer and I have to leave that to voters. Thanks for your time. – Iman Mohamadi Jul 16 at 12:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.