My laptop has very high resolution and I often want to change the scale factor. Until recently the following command worked just fine

gsettings set com.ubuntu.user-interface scale-factor "{'eDP1': 16 }"

But now I am getting the error

GLib-GIO-Message: Using the 'memory' GSettings backend.  Your settings will not be saved or shared with other applications.

I tried all the proposed solutions including the accepted answer in this post but none worked. If I open the dconf-editor GUI I can change the scale factor just fine but this is less convenient. I'm lost as to how to fix this but I would love to be able to change the scale factor via a command instead of a GUI.

1 Answer 1


Try running the following command line first:

export GIO_EXTRA_MODULES=/usr/lib/x86_64-linux-gnu/gio/modules/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.