4

I just installed a new distribution of Ubuntu 16.04 and have been configuring it, but something has been happening when the laptop lid is closed. After I close the lid for, say, 30 minutes, I will be left with a wide variety of programs opened on my screen (Typically the LibreOffice tools, about 5 file folders, my windows partition folder, and firefox).

It looks like this

My screen wasn't hibernating when I closed the lid (which didn't happen on my previous 14.04 installation), so I modified the /etc/systemd/logind.conf file to set HandleLidSwitch=hibernate.

This set the laptop screen to hibernate and lock my user properly when I closed the lid, but the problem still persisted. The clicks would just go into the guest user and do the same thing.

Some additional info:

My laptop is an HP Pavilion 360 (which has a touchscreen, could be significant?).

I have a wireless mouse plugged connected to the computer via a dongle, but the problem persists whether or not the wireless mouse is within range of the computer.

My power settings are currently configured like this.

Any help/suggestions would be greatly appreciated!

Edit:

From freedesktop.org's description of the logind.conf file:

A different application may disable logind's handling of system power and sleep keys and the lid switch by taking a low-level inhibitor lock ("handle-power-key", "handle-suspend-key", "handle-hibernate-key", "handle-lid-switch"). This is most commonly used by graphical desktop environments to take over suspend and hibernation handling, and to use their own configuration mechanisms. If a low-level inhibitor lock is taken, logind will not take any action when that key or switch is triggered and the Handle*= settings are irrelevant.

I assume that this means the Power Settings will take precedence over any changes that I make to the logind.conf file. Is there any way to override/customize these power settings other than through the settings interface?

  • Just to be safe set HandleLidSwitchDocked=hibernate as well. – WinEunuuchs2Unix Mar 2 '17 at 2:45
  • I have the same problem with my HP Pavilion with Ubuntu 18.04. Not touchscreen so I think we can exclude that. Did you find any solution for this? – Tuxedo Joe Oct 27 '18 at 6:44
0

Disabling the touchpad solved it for me. If you or someone else have the same problem, try installing touchpad-indicator and disable the touchpad while the lid is closed.

sudo add-apt-repository ppa:atareao/atareao
sudo apt-get update
sudo apt-get install touchpad-indicator

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.