So, I've been dealing with this problem for a while and decided to do something about it today. I'm dual booting Ubuntu 16.04 and Windows 10 on a Lenovo Yoga 13, and about half the time when I do a "hard click", that is, when I actually depress the left half of the touchpad until it clicks, it will react as if I've double clicked and registers two ButtonPress events according to xev. This is apparently a common problem in external mice, called "bouncing" or "rubbing" (via here), but I don't know what to do when it's a problem with the touchpad.

I first tried changing the settings through the Unity Mouse options and learned that by setting my double-click speed to absurdly high, I can get it to register as two separate single-clicks rather than a double-click, but that didn't solve the problem of the mouse bouncing. I then tried some of the settings in synclient (e.g. MaxTapTime, SingleTapTimeout, ClickTime) and tried to change the setting for "TouchpadOff" (it's currently set at 2 and I tried synclient TouchpadOff=0) to no effect.

After reading through some of the man pages and xorg documentation, I've learned that there's an option in some prior versions to disable "FastTaps", which sounds like it could be part of the problem. Any advice on this is welcome, and I'd actually settle for disabling the option to hard click the touchpad entirely (synclient ClickPad=0 didn't do it).

Other notes for diagnosis: If I hard click the right side of the touchpad to perform a right click, it'll record me right clicking then immediately left clicking. All "soft clicks" work perfectly, no bouncing. This has been a problem since I first installed Ubuntu 16.04, and I haven't tried any earlier versions on this laptop. This is never a problem in Windows.

This is my first post on askubuntu (woo!) and I'm not extremely familiar with Linux yet, so brownie points will go towards anyone who can explain what they're doing in essentially layman's terms.

  • Install libinput by sudo apt install xserver-xorg-input-libinput ant test how it works there. You need to reboot to get it working. tapping that you call "soft clicks" will be disabled by default, but can be enabled later.
    – Pilot6
    Mar 1, 2017 at 21:49
  • 1
    If you installed 16.04.2, you need to run sudo apt install xserver-xorg-input-libinput-hwe-16.04 instead.
    – Pilot6
    Mar 1, 2017 at 21:54
  • @Pilot6 The HWE version didn't work even though I've got 16.04.2, but the original one worked! If you post that as an answer, I'll mark it as correct.
    – Dubukay
    Mar 1, 2017 at 22:29
  • I added the answer.
    – Pilot6
    Mar 2, 2017 at 7:20

1 Answer 1


You can install the new user space touchpad driver that is called libinput.

It depends on which release did you initially installed, not what you see now. It looks like you installed 16.04, or 16.04.1.

In this case you can install libinput by

sudo apt install xserver-xorg-input-libinput

If you initially installed 16.04.2, or installed the HWE stack, then the command will be

sudo apt install xserver-xorg-input-libinput-hwe-16.04

Tapping may be disabled in libinput. You can enable it by adding

Option "Tapping" "true"

to the touchpad section of the /usr/share/X11/xorg.conf.d/90-libinput.conf file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.