I recently applied a fresh install of 11.10 server, and when the GRUB menu should appear on boot, my monitor says it doesn't support the current input timing. This is an LCD monitor, and I get a similar error on an older LCD monitor. Here are the uncommented lines in my /etc/default/grub:

GRUB_HIDDEN_TIMOUT=1 # changed to try getting the menu to appear
GRUB_TIMEOUT=10 # changed from 2
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`

After making the changes above, I ran update-grub which said it worked.

My motherboard is an ASRock N68-S board with GeForce 7025 / nForce 630a chipset.

If I don't press anything during this time, the kernel will boot and I'll get to a login prompt, however it's a problem because it hangs at this point once I get mdadm installed and my RAID drives connected. If I could see what's going on maybe it will help me diagnose that problem.

I have the exact same problem with a fresh install of 11.10 desktop; the login and desktop UI work fine, it's just when the GRUB menu should show up that I get nothing.


Your video card does not like your monitor enough to send it a signal it likes durign that time on its own, so you'll need to edit /etc/grub.d/00_header and tell it what to do.

In that file search for gfxmode=auto and change it to something like gfxmode=1024x768. If you don't feel comfortable doing it, you can use StartUp Manager https://help.ubuntu.com/community/StartUpManager to make the change.

  • Thanks very much for the response; I got it working by uncommenting GRUB_TERMINAL=console, but I'll give this a try too. Dec 23 '11 at 2:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.