2

On a Dell XPS 13 9360, running Ubuntu 16.04 and kernel 4.7.01, battery life is dismal. Powertop indicates power usage of Network interface: wlp58s0 (ath10k_pci) of sometimes 20w.

This -combined with a recurring issue with pulseaudio- really kills the battery life. Any tips on how to bring this down? I have already tried different kernels.

  • How long does battery last? If you have standard battery, I expect about 2:30. My Dell 5510 also has mediocre battery, but larger screen. – pauljohn32 Mar 21 '17 at 3:21
  • Go to /etc/NetworkManager/conf.d/ and do a grep --recursive --ignore-case power * then edit your question and provide the output and ping me @fabby – Fabby Mar 21 '17 at 11:42
  • please edit to define "dismal". How long does the battery last, and how long do you expect it to last? – James Mar 23 '17 at 2:15
  • Did this laptop ship with Ubuntu or Windows? If Windows, it'd be interesting to know if a variation between the Ubuntu and Windows versions results in your issue, or if 9360s that shipped with Ubuntu are also affected. – Robie Basak Mar 23 '17 at 13:27
  • it shipped with Ubuntu – Peeperkorn Mar 24 '17 at 15:14
2
+25

I have the XSP 13 9360 running on Ubuntu 16.04.2 and get fairly good battery life of about 6-10 hours depending on workload. I get about ~5-10W power draw with Chromium and light web browsing.

I have done these already

Installed TLP

for generally optimize power usage on battery

Installed the 4.11 rc1 kernel

Install it with Ukuu (easiest way and you also get Ubuntu patches) This should take care of the NVMe power drain since pre-4.11 kernels don't have NVMe power management at all

Installed the latest Intel video driver

Use the “Intel Graphics Installer for Linux”, this should take care of the necessary firmware items as well (huc, guc...etc) https://01.org/linuxgraphics/downloads

Added kernel parameters for the Intel video driver

https://wiki.archlinux.org/index.php/Dell_XPS_13_(9360)

Notes here: - don't forget update-initramfs after you added the config values - the "enable_huc" parameter seems to be invalid, you will see a boot message about it if you check it with dmesg

Installed Kodi

For watching videos in hw-accelerated way. Kodi uses vaapi by default whenever possible so much lower power drain.

Note: This seems to be the best way to play from SMB shares anyway, it is practically stutter free on my home network (wifi), while 1080p H264 was stuttering with the Ubuntu built-in Videos app.

Switched to Chromium for browsing

Seems like it draws much less power on the Javascript-heavy web pages I view regularly (less than the default installed Firefox).

I will play with Firefox multi-process later, I hope I can bring down power draw there as well.

Deactivated Bluetooth

Simply by using the panel applet.

Deactivated keyboard backlight when not needed

You don't need this most of the time but it seems to be quite a power hog. At least a 0.5W gain from average brightness to zero.

I also intend to try to configure these

Configure hw-accelerated video for Chrome, Firefox

VAAPI and VDPAU usage in the browser for hw-accelerated youtube watching in the browser https://oded.ninja/2016/10/30/optimizing-your-linux-distro-ninja-level/

Move /tmp to a tmpfs drive

So that the temporary files of the web browsers stay on a memory drive, hopefully further lowering power draw while browsing.

https://oded.ninja/2016/10/30/optimizing-your-linux-distro-ninja-level/

Investigate wifi power-draw

Seems like the Killer/Atheros wifi consumes 1.5W even if there is no network traffic (according to PowerTop). Maybe the power management is not activated at all on the driver.

Others

Let me know if you know any Ubuntu / Linux power optimizations I could use on this machine.

  • nice answer! Do you have the touchscreen edition? found that the screen is quite the power hog as well. i will try the 4.11 rc kernel today. Chromium and Chrome results in an odd flickering of the screen. (figured that's the same bug as reported here: en.community.dell.com/techcenter/os-applications/f/4613/t/… ). – Peeperkorn Mar 24 '17 at 15:19
  • hm. 4.11 rc1 crashes the computer. rc3 does as well. next up might be the 4.10 patched version. – Peeperkorn Mar 24 '17 at 16:00
  • I have the non-touchscreen, FHD version. Dont forget to update to 16.04.2 first. Install the kernel with Ukuu. – sola Mar 24 '17 at 18:37
  • The QHD screen is indeed a known powerhog although less so than in earlier XPS 13 models. I knowingly chose the FHD version to have better battery life with Ubuntu. – sola Mar 24 '17 at 18:39
1

Don't put too much emphasis on power top. I've not found that it points me in useful directions most of time.

Here is a laundry list of things I do.

  1. Disable bluetooth entirely (if not needed). I am absolutely sure this saves energy. BT device keeps scanning for new friends. I turn off bluetooth in BIOS (System settings. I know it is not technically BIOS now, UEFI or whatever looks same). I suppose your powertop output warns about BT separate from WIFI?.
  2. turn down screen brightness. If you use external monitor, turn off internal screen, is battery life better?
  3. Experiment with wifi. Use network manager to turn it off entirely. See if battery goes strong for a couple of hours. Recharge, try same with wireless. Dont believe powertop until you make this test. Then bugshoot. Sometimes problem is that wifi keeps itself in high energy mode looking for new connections. Monitor 'dmesg' for evidence of that. If you are in building with lots of wifi extenders, device may scan constantly. On mine, we had to hard code the wifi device ID last year.

Ubuntu 15.04, pm-utils do not look into /etc/pm/power.d/ anymore, what instead? CLAIMS that Network Manager no longer tries power management. It also says laptop mode tools and powertop don't cooperate with newest OS & hardware, recommend some seemingly adverturesome config changes. I don't know where truth lies.

  1. Hard disk access drains power. In terminal, run 'top' to make sure no busy jobs are running and that you have plenty free ram. If RAM is full, then disk usage as Swap will drain power. Also, don't let file system track access times. You will find "noatime" as recommendation to extend life of SSD, but also avoiding disk writes is smart. If doing serious computation, consider /dev/shm rather than tmp storage.
  2. Make sure pc uses CPU frequency scaling (Intel speedstep). It should drop clockspeed when system is not running big jobs. There are cpu freq monitoring apps, you should see freq drop to 800MHZ. If you have trouble, I can get my notes. There are commands to print cpu frequency. On one new system, I was surprised that BIOS had Speedstep didabled.

I hope others will have more "what really works" tips.

If your battery runs more than 3 hours, IMHO you are doing pretty well. I have Dell precision 5510 with 2 hard disks (ssd & SATA) and battery life is not great (2:30 usually). Three year old Dell ultrabook with largest battery can run 5:30. Newer laptop w Skylake cpu & such has never done as well. It has been improving--much better with 4.8 kernels than 4.3 in last fall. Still, never lasts more than 3 hours.

  • 1
    The 9360 has a 60Wh battery (one of the biggest in the 13" crowd) so even with the worst power drain it lasts 3 hrs. Mine lasts about 6-8 hrs with vanilla Ubuntu + 4.11rc1 kernel + tlp. However, I am not satisfied, it works much longer with Windows. – sola Mar 22 '17 at 20:55

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.