2

All I want to do in play a new game I bought on steam. When I run it, it gives me this error...

Detected OpenGL version: 3.0 Mesa 17.0.1-devel
Required OpenGL version: 3.3
Please update your display driver.

I have tried a bunch of things this last week and I just don't understand, then when I go to check my version it says I still have mesa 3.0 but my max core version profile 3.3 which is what I need.

laptop:~$  glxinfo | grep "OpenGL version"
OpenGL version string: 3.0 Mesa 17.1.0-devel
laptop:~$ glxinfo | grep core
    Preferred profile: core (0x1)
    Max core profile version: 3.3
OpenGL core profile version string: 3.3 (Core Profile) Mesa 17.1.0-devel
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
5

You should be able to force the OpenGL version string to 3.3 using the following prefix prior to the command used to launch your game:

MESA_GL_VERSION_OVERRIDE=3.3 command

For steam, you should be able to add this as a launch option (see here).

However, there is no guarantee that your game will run without issues if it does launch using this method. It also looks like you're using a development version of Mesa which may also not be stable.

My answer in this post may help explain the different Mesa versions listed by glxinfo.

11
  • Im sorry, Im a bit new to Linux but how do you open an app in steam with a command? Mar 1 '17 at 21:08
  • I've updated the answer for you.
    – gsxruk
    Mar 1 '17 at 21:25
  • So i figured out how to run the game via terminal, but this happend. ill just copy and paste it. Mar 1 '17 at 22:58
  • laptop:~$ MESA_GL_VERSION_OVERRIDE=3.3 command laptop:~$ steam steam://rungameid/239140 Running Steam on ubuntu 16.04 64-bit STEAM_RUNTIME is enabled automatically Installing breakpad exception handler for appid(steam)/version(1484790260) Installing breakpad exception handler for appid(steam)/version(1484790260) Mar 1 '17 at 23:01
  • 1
    You needed to replace "command" with the command to launch your program (for example MESA_GL_VERSION_OVERRIDE=3.3 glxinfo). If you're going to launch the game as you have above, try exporting the override first like this export MESA_GL_VERSION_OVERRIDE=3.3, press return and then launch your game using the command as you have above.
    – gsxruk
    Mar 2 '17 at 16:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.