4

Redshift seems to use the geoclue-2.0 package to get the location specification automatically upon its launch.

This usually works. However, whenever I don't have an active internet connection from the start, Redshift is unable to get my location and returns the error Unable to get location from provider.

For the case of a missing internet connection, how can I make Redshift use a custom location setting and not make it try to use geoclue?

4

You can provide your location (in terms of decimal degrees) to redshift using the -l switch, and it no longer needs geoclue.

In my case, I searched for "MY_CITY latitude longitude", entered dateandtime.info page, found the latitude and longitude of my city in decimal degrees, and provided them to redshift as indicated in the help and man page, namely redshift -l LAT:LON.

As an example, for New York, your can run redshift -l 40.71427:-74.00597.

  • All right, so I run that command and it doesn't work: Malformed argument. Failed to set manual option. Try '-l manual:help' for more information. – 6005 Mar 26 '17 at 5:40
  • Copy and pasted the command exactly and the man page agrees with what you said. I'm quite stumped. – 6005 Mar 26 '17 at 5:40
  • After I searched I found this bug, so it seems to be an incorrect configuration file. – Nour-eddin Mar 28 '17 at 19:17
  • Thanks. I was able to fix it by editing my configuration file. – 6005 Mar 29 '17 at 4:09
-1

You can use my free bash patch using a jq workaround on GutHub.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.