1

I cannot install synaptic on my Ubuntu 14.04 LTS PC. Getting the following error. What should I do?

enter image description here

2
  • 1
    Go to the terminal and run sudo apt update (type your password) then sudo apt upgrade. Then try installing Synaptic again.
    – anonymous2
    Commented Feb 28, 2017 at 12:26
  • 2
    If the above recommendation produces errors make sure to edit your question and post the full error messages.
    – user589808
    Commented Feb 28, 2017 at 12:30

1 Answer 1

3

Run the following commands in your terminal (Ctrl+Alt+t):

sudo apt clean
sudo apt update
sudo apt upgrade
sudo apt -f install
sudo apt install synaptic

When prompted, enter your password. This should install synaptic for you, along with clearing up broken packages (fixing dependency issues) and updating your system.

Special thanks to @DKBose for pointing out sudo apt clean. :)

2
  • @DKBose, excellent thoughts, thanks for pointing out. :)
    – anonymous2
    Commented Feb 28, 2017 at 12:43
  • 1
    @DKBose, it's still there: I'm guessing it's an oversight in the documentation.
    – anonymous2
    Commented Feb 28, 2017 at 12:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .