4

I am trying to install ImageMagick Library.
with the command:

sudo apt-get install libmagickwand-dev

But It give error like:

libmagickwand-dev : Depends: libmagickwand5 (= 8:6.7.7.10-6ubuntu3.4) but it is not going to be installed
Depends: libmagickcore5-extra (= 8:6.7.7.10-6ubuntu3.4) but it is not going to be installed
Depends: libmagickcore-dev (= 8:6.7.7.10-6ubuntu3.4) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

What is the solution of this type of problem?

  • Run sudo apt-get update && sudo apt-get upgrade and try again – M. Becerra Feb 28 '17 at 9:52
  • Its not working,still same error is occured. – kajal siyat Feb 28 '17 at 11:20
  • Manually install the depends packages that are not going to be installed. – L. D. James Feb 28 '17 at 11:26
  • 2
    'Held broken packages' often means a version conflict, usually caused by unsupported software from PPAs or other non-Ubuntu sources. Disable the source that is causing the problem, and uninstall all software from that source. Is this your very first try to install imagemagick packages? If not, what did you try before? – user535733 Feb 28 '17 at 12:34
  • its work when I install the depends manually – kajal siyat Feb 28 '17 at 12:42
3

First ensure your system's libraries are update by running:

$ sudo apt update
$ sudo apt upgrade

Then manually install the Depends that are displayed in the error message.

Then install the package as normal.

  • Ran into this issue as well. I had selected to download from "fastest mirror" in the "Software & Updates" section. I WAS able to fix it by "apt-get update" and "apt-get upgrade" but ONLY AFTER switching back to "Server for United States" – Andrew P Oct 19 '17 at 17:47
-1

I met the same problem.

system: Linux mint 18.1 "Serena"

When I did like this:

$ sudo apt-get install vlc browser-plugin-vlc

Outcomes:

sudo: unable to resolve host mint
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
vlc : Depends: vlc-nox (= 2.2.2+git20170601+r59025+56~ubuntu16.04.1) but it is not going to be installed
Depends: libavcodec-ffmpeg56 (>= 7:2.4) but it is not going to be installed or
libavcodec-ffmpeg-extra56 (>= 7:2.4) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I tried many methods that i can search on the net, such like:

$ sudo apt-get update 
$ sudo apt-get upgrade

$ sudo apt-get update --fix-missing

$ sudo apt-get autoclean $$ apt-get clear cache

and so on.

But those can help me to solve the problem.

I also see Synaptic Package Manager --> Custom Filters --> Broken, there were no broken package.

Finally, I changed the software source, then I tried

 $ sudo apt-get install vlc browser-plugin-vlc

The problem was solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.