11

This question already has an answer here:

Out of the blue I started getting these weird borders around my windows. It either happens after coming back from full-screen applications, or after system resume. A reboot fixes this problem, but only temporarily. I have not updated my graphics drivers (not manually, automatically maybe) or had any problems since installing last year.

My video card is a NVIDIA Quadro K1000M, and I've been using NVIDIA binary driver version 375.39 since launch. I have not yet tried tinkering with the drivers, seeing if it would fix the problem or not.

image of white borders

marked as duplicate by Eliah Kagan, Eric Carvalho, Pilot6, Zanna, Kaz Wolfe Sep 25 '17 at 2:28

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • I have the exact same problem, and the weird borders are even wider on my computer. This indeed appeared after a system update which installed the 378 drivers but kept the 375 in use. So I tried with the 378 without luck. My kernel is 4.8.17-040817-generic and my card a 960M. Any help will be greatly appreciated ! – ddidier Mar 2 '17 at 10:15
  • here's a gist for the relevant packages update, or I hope so. @a-stroh : can you try to find common updates in your /var/log/apt/history.log ? – ddidier Mar 2 '17 at 10:41
8

The culprit is the new version of the NVidia driver. Reverting to 375 doesn't work because IMHO it has also been updated (minor version) and/or its dependencies are a mix of several versions. Anyway:

  1. Remove the PPA. On my computer I deleted the file /etc/apt/sources.list.d/graphics-drivers-ubuntu-ppa-xenial.list pointing to the repository deb http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu xenial main
  2. Remove all the installed NVidia packages, i.e. nvidia-*. On my computer I deleted several packages with apt remove nvidia-361 nvidia-375 nvidia-378
  3. Update the packages list with apt update
  4. Install the last official version (i.e. 367) with apt install nvidia-367

As a side note, I'm always amazed how updates regularly break Ubuntu...

  • Thanks, that fixed the issue for me. Same feelings here regarding the updates. Despite this clearly being nVidia's fault, at this stage I am considering not touching anything other than the major security updates with a ten foot pole and only upgrading via LTS releases where everything is thoroughly tested together. – Alex Fedulov Mar 5 '17 at 11:48
  • I sadly must use an unofficial kernel (mainline PPA) to support my laptop :-( Please consider validating my answer – ddidier Mar 6 '17 at 13:11
  • Completely out of scope, but quoting Linus Torvalds seems appropriate: "Nvidia, Fuck You". Source: youtube.com/watch?v=iYWzMvlj2RQ. Should have bought a different laptop... Thanks for the answer, it helped but gave me different problems with modal windows on top of others. – Joe Eifert Jul 4 '17 at 12:31
6

Its' not a solution per se, but it helps to get the white borders removed.

We just need to restart the Unity, by using the following command -

unity --replace,

which will restart the Desktop Manager, but will keep are current Session intact.

So no logout/login needed, just call the above command whenever these NVIDIA drivers create your screen unusable.

EDIT-

Have tried this solution only on Ubuntu, so I guess most of the Debian Distro's will work here, but not sure about any other Linux Distro.


UPDATE

Above Solution was a temporary one... As it is true that latest drivers of NVIDIA breaks Ubuntu... I guess u should try the solution in the following link - Strange artifacts along window borders

As nvidia-367 updates itself automatically to nvidia-375, we need to get a stable nvidia-370, which doesn't update itself. This solved my issue, but I am still not convinced, as I still get screen tearing when watching a high-res video...

1

Updating the Nvidia driver to 384.69 solved the issue for me.

In "Software and Updates" open "Additional drivers" tab an there should be "nvidia-384" option available. Select->Apply Changes->Restart

If not then visit: http://www.nvidia.com/object/unix.html

Not the answer you're looking for? Browse other questions tagged or ask your own question.